Community discussions

MikroTik App
 
paulchops
newbie
Topic Author
Posts: 43
Joined: Sat Feb 02, 2008 6:33 pm

Problem with Script for Simple Queue

Sat Feb 02, 2008 8:31 pm

I have used this script (minus the three burst "variables") for a while successfully. When I add the three burst items, the script doesnt run. It does nothing, as though there is an error in it. I pasted the same "effectual" string into a terminal window and it works fine.

I am relatively new to scripts (the ones I know were initially created for me by someone else) so its probably a newbie issue.

Thanks!

Paul McCall, PDMNet


#New Script To Auto Create Simple Queues For A Subnet:
#Enter the First 3 Octets of your Subnet Here! (I am using 192.168.0 only in this pasted example)
:local subnet "192.168.0."

#The Interface on which you wish to apply the Queues
:local inface "all"

#The Queue Priority Level .. 8 is Generally Sufficient for User Base Queues
:local qu-pri "8"

/queue simple
:for i from=130 to= 158 do = {
:if ([/queue simple find target-addresses=($subnet . $i)] = "") do={ /queue simple add \
name=($subnet . $i) target-addresses=($subnet . $i) dst-address=0.0.0.0/0 \
interface=$inface parent=none priority=$qu-pri \
queue=default-small/default-small max-limit=1000000/4000000 \
burst-limit=1500000/6500000 burst-threshold=1350000/5500000 burst-time=20s/20s }
}

Who is online

Users browsing this forum: No registered users and 16 guests