We are having a similar problem. We just upgraded our 2.9.49 hotspot to 3.11 and are receiving some strange behavior. This system had been working for a couple years prior, then after upgrading it to 3.11, attempting to access our hotspot homepage through the walled garden results in half loaded web pages. We tried downgrading to 3.10 and had the same results.
A little more detail on what is happening:
- 1. When a user connects to the hotspot, we immediately redirect them to a page, register.cramerit.net, through the walled garden. (We have walled garden rules added for this - see the export below).
- 2. We frame in the login page to the router with an iframe.
The redirect from rlogin.html is working fine, but the destination page will not fully load. The html gets truncated. If you repeatedly try to reload the page, it will get varying degrees of truncation and sometimes will mostly load, but it is very inconsistent.
If I disable hotspot, the page loads right up with no problem. Also, if you can mange to authenticate with hotspot running, all other web pages load fine.
The only page having trouble is the hotspot home page that is accessed through the walled garden.
There is clearly a problem here - can anyone tell me what is wrong?
# jul/16/2008 20:59:46 by RouterOS 3.10
/ip hotspot profile
set default dns-name="" hotspot-address=0.0.0.0 html-directory="" \
http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap \
name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
use-radius=no
add dns-name="" hotspot-address=12.201.133.254 \
html-directory=hotspot http-cookie-lifetime=8w4d http-proxy=0.0.0.0:0 \
login-by=cookie,http-chap,http-pap name=hsprof1 nas-port-type=\
wireless-802.11 radius-accounting=yes radius-default-domain="" \
radius-interim-update=1m radius-location-id="" radius-location-name="" \
rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=yes
/ip hotspot
add disabled=yes idle-timeout=none interface=Hotspot keepalive-timeout=none \
name=server1 profile=hsprof1
add disabled=yes idle-timeout=none interface="ether 2 - Students" \
keepalive-timeout=none name=newserver profile=hsprof1
/ip hotspot user profile
set default advertise=no idle-timeout=8w4d keepalive-timeout=5m name=default \
open-status-page=always shared-users=1 status-autorefresh=1m \
transparent-proxy=yes
/ip hotspot ip-binding
add address=10.2.7.0/24 comment="" disabled=no type=bypassed
add address=10.0.0.0/8 comment="" disabled=yes server=server1 type=bypassed
add address=12.201.133.10 comment="" disabled=yes server=server1 type=\
bypassed
add address=12.201.132.125 comment="" disabled=yes type=bypassed
add address=12.201.132.226 comment="" disabled=no type=bypassed
/ip hotspot service-port
set ftp disabled=no ports=21
/ip hotspot user
add comment="" disabled=no name=admin password=jazkot&76 profile=default
/ip hotspot walled-garden
add action=allow comment="" disabled=no dst-host=register.cramerit.net \
dst-port=80 server=newserver
add action=allow comment="" disabled=no dst-host=register.cramerit.net \
dst-port=443 server=newserver
add action=allow comment="" disabled=no dst-host=12.201.197.1 dst-port=80 \
server=newserver
add action=allow comment="" disabled=no dst-host=12.201.197.1 dst-port=443 \
server=newserver