Page 1 of 1

Script to send Dynamic IP address to me in E-mail?

Posted: Mon Jul 05, 2004 5:22 am
by jroy
You have a Script to send Dynamic IP address to me in E-mail via an smtp server that requires authentication?

Posted: Mon Jul 05, 2004 3:36 pm
by edzix
first you have to configure your SMTP server under '/tool e-mail', then make a script which will send an email including the necessary IP as body parameter. Like this:
----------
:local ip
/ip address{
:foreach i in [find dynamic=yes] do={:set ip [get $i address]}
/tool e-mail send to=someone@somewhere body=(" Dynamic IP found:" . $ip)
}
-----------

Edgars

Where are the username and password settings?

Posted: Mon Jul 05, 2004 8:16 pm
by jroy
----------
:local ip
/ip address{
:foreach i in [find dynamic=yes] do={:set ip [get $i address]}
/tool e-mail send to=someone@somewhere body=(" Dynamic IP found:" . $ip)
}
-----------
So where are the username and password settings? I have only smtp servers that require authentication. I do not have a single server that does not require authentication.

Posted: Tue Jul 06, 2004 1:35 pm
by edzix
e-mail settings could be configured under '/too e-mail' submenu. See the manual for more information;
http://www.mikrotik.com/docs/ros/2.8/tools/email.main

Edgars

Again

Posted: Tue Jul 06, 2004 8:53 pm
by jroy
AGAIN,

WHERE DO YOU SET THE USERNAME AND PASSWORD FOR THE SMTP SERVER????

Posted: Tue Jul 06, 2004 10:02 pm
by changeip
I thought Mikrotik supported smtp auth as well, but I dont see the commands that support it anywhere... i guess they dont.

Sam

Posted: Wed Jul 07, 2004 9:57 am
by cmit
You should just go to the MikroTik download page http://www.mikrotik.com/download.html where you'll find your Windows MAC Telnet Client at the bottom of the page (which has been there at least since February 2003...).

Regarding SMTP auth: Yes, this would be handy...

Posted: Wed Jul 07, 2004 9:59 am
by cmit
Ooops?! I actually responded to a post from "jroy" where he was stating he won't carry a MikroTik router everywhere just to able to use MAC Telnet and was asking for a Windows MAC telnet client.

Looks like his post just got removed...