Page 1 of 1

i found way to detect the spoof or arp program just try it

Posted: Sat Apr 25, 2009 2:23 pm
by mohamed
I found a way to detect the spoof or ARP program

kindly do the following:

1-add the rule in the new terminal
2-edit this rule by yourself
3-remove all IPs from address list
4-try to run Net Cut to find if the Microtik detected it or not


first,add this code in the new terminal

/ip firewall filter

add action=reject chain=forward comment="Reject if in the 24-hour-list" disabled=no reject-with=icmp-network-unreachable src-address-list=24-hour-list

add action=jump chain=forward comment="Check if dest is an open customer" disabled=no dst-address-list=open-customers jump-target=open-customers
add action=jump chain=forward comment="Check Known Bad Hosts" disabled=no jump-target=bad-hosts
add action=reject chain=forward comment="Reject if in the 24-hour-list" disabled=no reject-with=icmp-network-unreachable src-address-list=24-hour-list

add action=return chain=bad-host-detection comment="Take no action on bogons" disabled=no src-address-list=bogons
add action=add-src-to-address-list address-list=30-seond-list address-list-timeout=30s chain=bad-host-detection comment="Add to the 30 second list" disabled=no

add action=add-src-to-address-list address-list=24-hour-list address-list-timeout="1d 00:00:00" chain=bad-host-detection comment="If seen 20 time in 30 seconds add to the one day block list" disabled=no nth=50 src-address-list=30-seond-list
add action=return chain=bad-host-detection comment="" disabled=no


add action=jump chain=forward comment="jump to the bad-host-detection chain" disabled=no jump-target=bad-host-detection src-address-list=!our-networks

add action=jump chain=forward comment="jump to the bad-host-detection chain" disabled=no jump-target=bad-host-detection src-address-list=!our-networks
add action=log chain=forward comment="log and reject the rest" disabled=no log-prefix=""
add action=reject chain=forward comment="" disabled=no reject-with=icmp-network-unreachable



2-follow the next pic to edit this rule





Image



But change 192.168.0.0/24 to your network IP


3-remove all IPs from the network like this pic


Image


4-try to run Net Cut

After 10 seconds you will see the IP in the "30 seconds list"

Image



After 10 seconds you will see the IP in the "24 list"
Image

As you see the Microtik catch the IP he run net cut

Re: i found way to detect the spoof or arp program just try it

Posted: Mon Apr 27, 2009 9:16 am
by NetworkPro
Thank you!!! Very useful.

Re: i found way to detect the spoof or arp program just try

Posted: Sat Nov 13, 2010 4:47 pm
by namo
Do I need to put these firewall rule at the top?
Do they work with v4.13

Re: i found way to detect the spoof or arp program just try

Posted: Sat Nov 13, 2010 8:52 pm
by capital
Very Good indeed...

Now if we could only redirect browser traffic to a page saying:

"We have detected Netcut or Arp tool running in your system. Thus we have blocked your traffic for XXseconds. Please unistall to avoid further inconviencies"

That would be awesome !

Capital

Re: i found way to detect the spoof or arp program just try

Posted: Sat Nov 13, 2010 9:55 pm
by namo
the problem that netCut still show some IPs and mac and the user can change his as those.

We need a code that prevent a mac address with different host in short time (shorter than the keep alive time)

Re: i found way to detect the spoof or arp program just try

Posted: Wed Nov 17, 2010 4:42 am
by otgooneo
Thank you mohamed, that is very helpful. Also this detector can detect all progams like netcut? For example: wireshark?

Re: i found way to detect the spoof or arp program just try

Posted: Wed Nov 17, 2010 5:51 am
by mahnet
thanks

Re: i found way to detect the spoof or arp program just try

Posted: Wed Jan 26, 2011 3:03 pm
by awayand
hello mohamed, can you repost the images as they are not visible anymore and I would like to try this... thanks!

Re: i found way to detect the spoof or arp program just try

Posted: Fri Oct 21, 2011 7:51 pm
by phantom19
hello mohamed, can you repost the images as they are not visible anymore and I would like to try this... thanks!
same thing here, requesting for the image upload, or please send links to my private messages.

Re: i found way to detect the spoof or arp program just try

Posted: Sat Oct 22, 2011 6:59 am
by NetworkPro
Copy of the original posters images:
jpg_003.jpg
Copy of the original posters images:
jpg.jpg
Copy of the original posters images:
jpg_002.jpg
Copy of the original posters images.

Re: i found way to detect the spoof or arp program just try

Posted: Sat Oct 22, 2011 7:00 am
by NetworkPro
Copy of the original posters images:
jpg_004.jpg

Re: i found way to detect the spoof or arp program just try

Posted: Tue Oct 25, 2011 3:10 am
by phantom19
Good thing I had a Backup huh :lol:
It is 07.08 AM at my office, and you have brighten my day!

THANK YOU mohamed and NetworkPro, best wishes for you all.

Re: i found way to detect the spoof or arp program just try

Posted: Wed Oct 26, 2011 9:38 pm
by bassembotros
i have already setup my mikrotik server v (5.7)
and i used the fake gateway to perevent the netcut
but there is a strange thing happened :
when i open the netcut on my PC
i found a many numbers of IPs ( unlimited numbers ) is this a type of hacking or what >?!
here is the PIC
Image

Re: i found way to detect the spoof or arp program just try

Posted: Mon Jan 23, 2012 10:19 am
by Gareth
I'm running v4.6 and when I add the code via the terminal I get an error with this piece of code:
add action=add-src-to-address-list address-list=24-hour-list address-list-timeout="1d 00:00:00" chain=bad-host-detection comment="If seen 20 time in 30 seconds add to the one day block list" disabled=no nth=50 src-address-list=30-seond-list
Error: failure: nth_every and nth_packet must be >= 0

Does anyone know what that means and how to fix it?

Re: i found way to detect the spoof or arp program just try

Posted: Mon Jan 23, 2012 2:43 pm
by janisk
to protect your networks from this - set up wireless encryption and for wired network set up encrypted pppoe.

Re: i found way to detect the spoof or arp program just try

Posted: Mon Jan 23, 2012 3:01 pm
by NetworkPro
PPPoE requires additional processing and software layer that adds high probability of issues including CPU consumption

Re: i found way to detect the spoof or arp program just try

Posted: Mon Jan 23, 2012 3:09 pm
by janisk
use that additional security as required. I really doubt that "smart-guys" are all over the network. And yes, it is only way how to protect the network from them as there is no way around it other but brake the encryption.

Re: i found way to detect the spoof or arp program just try

Posted: Mon Jan 23, 2012 3:37 pm
by NetworkPro
port isolation (port protected), DHCP or better static assignment, VRRP, MSTP, per-client VLANs if it will be cheaper

Re: i found way to detect the spoof or arp program just try

Posted: Tue Jan 24, 2012 9:46 am
by janisk
how exactly that will save you from someone who sniffs the traffic and spoofs IP/MAC of your device?

Re: i found way to detect the spoof or arp program just try

Posted: Tue Jan 24, 2012 12:42 pm
by NetworkPro
Access switches with security features.

Re: i found way to detect the spoof or arp program just try

Posted: Wed Jan 25, 2012 4:29 pm
by janisk
care to post some exapmles - what switches, links to documentation?

else it looks like trolling :)

Re: i found way to detect the spoof or arp program just try

Posted: Wed Jan 25, 2012 7:45 pm
by NetworkPro
Sorry I should have been more clear.

Port Isolation.

A switch that is able to send traffic from the access port only to the trunk port so it never reaches other access ports. Port isolation.

Re: i found way to detect the spoof or arp program just try

Posted: Thu Jan 26, 2012 12:00 pm
by janisk
namely VLAN with something similar to default-forwarding in wireless? If so, you can still sniff the traffic and notice the vlan tag, or that is me over-simplifying?

IMHO - security through obscurity is only disaster waiting to happen.

Re: i found way to detect the spoof or arp program just try

Posted: Thu Jan 26, 2012 1:02 pm
by NetworkPro
What is your argument exactly ?

Re: i found way to detect the spoof or arp program just try

Posted: Thu Jan 26, 2012 1:26 pm
by janisk
switch in the middle, mirror port - problem solved :)

Re: i found way to detect the spoof or arp program just try

Posted: Thu Jan 26, 2012 1:32 pm
by NetworkPro
Physical access is a separate topic.

Re: i found way to detect the spoof or arp program just try

Posted: Thu Jan 26, 2012 1:39 pm
by janisk
Cutting, crimping cable and sticking switch in the middle does not take a lot of time. Of course, if there is a network that is less protected (even not obscured) attacker will go with that one.

Adding a bit more powerful router with PPPoE server and using cheaper switches costs the same and offers more security not giving any change to attacker. drop in RADIUS server to manage logins.

Re: i found way to detect the spoof or arp program just try

Posted: Thu Jan 26, 2012 1:50 pm
by NetworkPro
why not

Re: i found way to detect the spoof or arp program just try

Posted: Wed Feb 01, 2012 1:15 pm
by Chupaka
when user have to remember its login and password - it's bad :)

direct access ruleZ!

IP-MAC-Port binding + DHCP Shooping on access switches do the work for us

Re: i found way to detect the spoof or arp program just try

Posted: Mon Sep 24, 2012 2:31 pm
by kembiet
Hi There!
Is it really working?

ros code

/ip firewall filter
add action=reject chain=forward comment="Reject if in the 24-hour-list" disabled=no reject-with=icmp-network-unreachable src-address-list=24-hour-list 
add action=jump chain=forward comment="Check if dest is an open customer" disabled=no dst-address-list=open-customers jump-target=open-customers 
add action=jump chain=forward comment="Check Known Bad Hosts" disabled=no jump-target=bad-hosts 
add action=reject chain=forward comment="Reject if in the 24-hour-list" disabled=no reject-with=icmp-network-unreachable src-address-list=24-hour-list 
add action=return chain=bad-host-detection comment="Take no action on bogons" disabled=no src-address-list=bogons 
add action=add-src-to-address-list address-list=30-seond-list address-list-timeout=30s chain=bad-host-detection comment="Add to the 30 second list" disabled=no 
add action=add-src-to-address-list address-list=24-hour-list address-list-timeout="1d 00:00:00" chain=bad-host-detection comment="If seen 20 time in 30 seconds add to the one day block list" disabled=no nth=50 src-address-list=30-seond-list 
add action=return chain=bad-host-detection comment="" disabled=no 
add action=jump chain=forward comment="jump to the bad-host-detection chain" disabled=no jump-target=bad-host-detection src-address-list=!our-networks 
add action=jump chain=forward comment="jump to the bad-host-detection chain" disabled=no jump-target=bad-host-detection src-address-list=!our-networks 
add action=log chain=forward comment="log and reject the rest" disabled=no log-prefix="" 
add action=reject chain=forward comment="" disabled=no reject-with=icmp-network-unreachable

Re: i found way to detect the spoof or arp program just try it

Posted: Wed Dec 20, 2017 9:34 pm
by engbassamy
guys i have executed the rules in the above , and i have got trouble in internet connection it's break down even though I cleared all the ip in address list , I need your help please.