Community discussions

MikroTik App
 
User avatar
agsochi
newbie
Topic Author
Posts: 26
Joined: Wed Apr 22, 2009 8:41 pm

Please help with traffic prioritization

Thu Nov 05, 2009 4:57 pm

Hi!
I use Simple Queues on RB450G to shape traffic in iCafe (My iCafe software support RouterOS remote manage).
1 ip - 1 simple queue.
I cant use trees because each IP simple queue is changing (128K, 512k, 2M) throw ssh depending on client (econo, standart, turbo).
How to prioritise traffic and use simple queues?
Mark connections and then packets in mangle prerouting or forward? What parent use in queue tree?
And can I use tree with simple queues together? In simple queues to manage bandwith, in tree - priority?
See below right or wrong?

Thanks for any help! :)
/ip firewall mangle
add action=mark-connection chain=forward comment=DNS disabled=no dst-port=53 new-connection-mark=dns-conn passthrough=yes protocol=udp
add action=mark-connection chain=forward comment="" disabled=no dst-port=53 new-connection-mark=dns-conn passthrough=yes protocol=tcp
add action=mark-packet chain=forward comment="" connection-bytes=0-100000 connection-mark=dns-conn disabled=no new-packet-mark=dns-traff passthrough=no
add action=mark-packet chain=forward comment=ICMP disabled=no new-packet-mark=icmp-traff passthrough=no protocol=icmp
add action=mark-connection chain=forward comment="RADMIN" disabled=no dst-port=22,23,4899 new-connection-mark=radmin-conn passthrough=yes protocol=tcp
add action=mark-packet chain=forward comment="" connection-mark=radmin-conn disabled=no new-packet-mark=radmin-traff passthrough=no
add action=mark-connection chain=forward comment=HTTP connection-bytes=1-500000 disabled=no dst-port=80,443 new-connection-mark=http-conn passthrough=yes protocol=tcp
add action=mark-packet chain=forward comment="" connection-mark=http-conn disabled=no new-packet-mark=http-traff passthrough=no
add action=mark-connection chain=forward comment=HTTP-2 connection-bytes=500000-0 disabled=no dst-port=80,443 new-connection-mark=http2-conn passthrough=yes protocol=tcp
add action=mark-packet chain=forward comment="" connection-mark=http2-conn disabled=no new-packet-mark=http2-traff passthrough=no
add action=mark-connection chain=forward comment="MAIL, ICQ" disabled=no dst-port=25,110,143,587,993,995,5190 new-connection-mark=mail-conn passthrough=yes protocol=tcp
add action=mark-packet chain=forward comment="" connection-mark=mail-conn disabled=no new-packet-mark=mail-traff passthrough=no
add action=mark-connection chain=forward comment=P2P disabled=no new-connection-mark=p2p-conn p2p=all-p2p passthrough=yes
add action=mark-connection chain=forward comment="" disabled=no new-connection-mark=p2p-conn passthrough=yes protocol=udp src-port=38472
add action=mark-packet chain=forward comment="" connection-mark=p2p-conn disabled=no new-packet-mark=p2p-traff passthrough=no
add action=mark-connection chain=forward comment="OTHER HEAVY" connection-bytes=500000-0 connection-rate=500k-100M disabled=no new-connection-mark=other-heavy-conn \
    passthrough=yes protocol=tcp
add action=mark-connection chain=forward comment="" connection-bytes=500000-0 connection-rate=500k-100M disabled=no new-connection-mark=other-heavy-conn passthrough=yes \
    protocol=udp
add action=mark-packet chain=forward comment="" connection-mark=other-heavy-conn disabled=no new-packet-mark=other-heavy-traff passthrough=no
add action=mark-connection chain=forward comment=OTHER disabled=no new-connection-mark=other-conn passthrough=yes
add action=mark-packet chain=forward comment="" connection-mark=other-conn disabled=no new-packet-mark=other-traff passthrough=no

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=total-global-in parent=bridge priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=http2 packet-mark=http2-traff parent=total-global-in priority=5 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=icmp packet-mark=icmp-traff parent=total-global-in priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=radmin packet-mark=radmin-traff parent=total-global-in priority=2 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=other packet-mark=other-traff parent=total-global-in priority=7 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=mail packet-mark=mail-traff parent=total-global-in priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=download packet-mark=p2p-traff,other-heavy-traff parent=total-global-in priority=8 \
    queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=http packet-mark=http-traff parent=total-global-in priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=dns packet-mark=dns-traff parent=total-global-in priority=1 queue=default

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=192.168.0.1/32 interface=all limit-at=0/0 max-limit=50M/50M name=ftp \
    parent=none priority=8 queue=default-small/default-small target-addresses=192.168.53.0/24 total-queue=default-small
add burst-limit=0/8M burst-threshold=0/4M burst-time=0s/8s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=8M/7M name=main \
    parent=none priority=1 queue=pcq-upload/pcq-download total-queue=default
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=yes dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=0/0 name=astaserver \
    parent=main priority=1 queue=default/default target-addresses=192.168.0.1/32 time=0s-1d,sun,mon,tue,wed,thu,fri,sat total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=500k/500k name=comp-1 \
    parent=main priority=5 queue=default-small/default-small target-addresses=192.168.0.101/32 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=120k/120k name=comp-2 \
    parent=main priority=7 queue=default-small/default-small target-addresses=192.168.0.102/32 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=yes dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=0/0 name=comp-3 \
    parent=main priority=8 queue=default-small/default-small target-addresses=192.168.0.103/32 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=120k/120k name=comp-4 \
    parent=main priority=7 queue=default-small/default-small target-addresses=192.168.0.104/32 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=yes dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=0/0 name=comp-5 \
    parent=main priority=8 queue=default-small/default-small target-addresses=192.168.0.105/32 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=500k/500k name=comp-6 \
....

Who is online

Users browsing this forum: certinet, che, naazh, wispmikrotik and 71 guests