Community discussions

MikroTik App
 
-headstrong-
Member
Member
Topic Author
Posts: 377
Joined: Thu Jun 05, 2008 8:04 pm
Location: South Africa

Scripts to monitor OSPF?

Sun Dec 20, 2009 9:47 pm

Hi Guys

Do any of you have some nice scripts that I can use to monitor OSPF? I've written a script that monitors the number of OSPF routes and emails me if this number changes...but there must be an easier and more accurate way of monitoring OSPF as my below script spammed my inbox :/
:local count
:local normal (63)
:local identity [/system identity get name]
:local time [/system clock get time]
:local date [/system clock get date]

:set count [/ip route print count-only where distance=110]

:if ($count!=$normal) do={
:log info ($count)
:log info ("ospf unstable")
/ip route print file="OSPF-ROUTES" where distance=110
/tool e-mail send to=xxx from=xxx subject=("$identity has updated OSPF routes") body=("from $normal to $count") file="OSPF-ROUTES.txt"
} else={
:log info ("OSPF stable")
}
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6263
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Scripts to monitor OSPF?

Wed Dec 23, 2009 10:53 am

use SNMP for that and print oid values to monitor that.
 
Megaboriss
just joined
Posts: 8
Joined: Mon Sep 03, 2018 6:31 pm

Re: Scripts to monitor OSPF?

Thu Oct 25, 2018 12:35 pm

@janisk can you please provide SNMP OIDs for OSPF monitoring?

Who is online

Users browsing this forum: No registered users and 7 guests