Ok here is what I think you can do because you will have to put some money into this. I say you get your self a 750G make sure it is upgraded to the latest ROS4.x and then enable the switch port in it. Once you have done this then make one your feed interface have all of the VLANS on it VLAN 1-4 or so.. Then make a bridge with each interface and a VLAN on it. Do this to all of your ethernet interfaces. Once you have done this you should be able to do a Port based VLAN isolation per AP that is plugged into each interface. This should help in broadcast storms. You can also go further and once the IPs are linked to a VLAN id and are tagged you can VLAN off your other class C (/24) networks. This should help you in further reducing noise. Also on your transparent firewall (the RB750G) you can implement a series of rules such as this:
/ip firewall filter
add chain=forward connection-state=established comment="allow established connections"
add chain=forward connection-state=related comment="allow related connections"
add chain=forward connection-state=invalid action=drop comment="drop invalid connections"
add chain=virus protocol=tcp dst-port=135-139 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=udp dst-port=135-139 action=drop comment="Drop Messenger Worm"
add chain=virus protocol=tcp dst-port=445 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=udp dst-port=445 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=tcp dst-port=593 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1080 action=drop comment="Drop MyDoom"
add chain=virus protocol=tcp dst-port=1214 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1363 action=drop comment="ndm requester"
add chain=virus protocol=tcp dst-port=1364 action=drop comment="ndm server"
add chain=virus protocol=tcp dst-port=1368 action=drop comment="screen cast"
add chain=virus protocol=tcp dst-port=1373 action=drop comment="hromgrafx"
add chain=virus protocol=tcp dst-port=1377 action=drop comment="cichlid"
add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment="Worm"
add chain=virus protocol=tcp dst-port=2745 action=drop comment="Bagle Virus"
add chain=virus protocol=tcp dst-port=2283 action=drop comment="Drop Dumaru.Y"
add chain=virus protocol=tcp dst-port=2535 action=drop comment="Drop Beagle"
add chain=virus protocol=tcp dst-port=2745 action=drop comment="Drop Beagle.C-K"
add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment="Drop MyDoom"
add chain=virus protocol=tcp dst-port=3410 action=drop comment="Drop Backdoor OptixPro"
add chain=virus protocol=tcp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=udp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=tcp dst-port=5554 action=drop comment="Drop Sasser"
add chain=virus protocol=tcp dst-port=8866 action=drop comment="Drop Beagle.B"
add chain=virus protocol=tcp dst-port=9898 action=drop comment="Drop Dabber.A-B"
add chain=virus protocol=tcp dst-port=10000 action=drop comment="Drop Dumaru.Y"
add chain=virus protocol=tcp dst-port=10080 action=drop comment="Drop MyDoom.B"
add chain=virus protocol=tcp dst-port=12345 action=drop comment="Drop NetBus"
add chain=virus protocol=tcp dst-port=17300 action=drop comment="Drop Kuang2"
add chain=virus protocol=tcp dst-port=27374 action=drop comment="Drop SubSeven"
add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot, Agobot, Gaobot"
add chain=forward action=jump jump-target=virus comment="jump to the virus chain"
And then to help with VoIP
#first part for only adding in VOIP priority QOS
/ip firewall mangle
add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-port=21,69,2400 new-connection-mark=VOIP_TRAFFIC passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-port=4569,5036 new-connection-mark=VOIP_TRAFFIC passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-port=5060-5061 new-connection-mark=VOIP_TRAFFIC passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-port=5004-5005 new-connection-mark=VOIP_TRAFFIC passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=VOIP disabled=no dst-port=10000-20000 new-connection-mark=VOIP_TRAFFIC passthrough=yes protocol=udp
add action=mark-packet chain=prerouting comment=VOIP connection-mark=VOIP_TRAFFIC disabled=no new-packet-mark=VOIP_PACKET passthrough=yes
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=0/0 name=VOIP packet-marks=VOIP_PACKET parent=none priority=1 queue=ethernet-default/ethernet-default target-addresses=0.0.0.0/0 total-queue=default-small
move VOIP 2
#USed if they do not have the p2p
/ip firewall mangle
add action=mark-connection chain=prerouting comment=p2p disabled=no new-connection-mark=p2p_conn p2p=all-p2p passthrough=yes
add action=mark-packet chain=prerouting comment=p2p connection-mark=p2p_conn disabled=no new-packet-mark=p2p_pack passthrough=yes
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=1000/64000 name="p2p outbound timed" packet-marks=p2p_pack parent=none priority=8 queue=ethernet-default/ethernet-default target-addresses=0.0.0.0/0 time=6h-23h,sun,mon,tue,wed,thu,fri,sat total-queue=default-small
Script to do p2p move should be:
/queue simple move "P2P" 0
/queue simple move VOIP 0
Never give up! Never surrender!
The advantage that WISPs have over the bulky corps are that you can provide services with a face and take cash check and do month to month plans. While a lot of big corps demand a 2-3 year contract with price locking. Sure you may not have the bulk bandwidth to drop down on the CPEs but you have the reliable hardcore WISP attitude of low latency and good bandwidth that is clean with packet shaping and prioritizing. Always sell your self as clear package that can allow the customer to use your VAR services like VoIP and the like. Hell make it worth your service to hookup their Xbox as part of the deal or run a cable from one room to the other professionally. Or feed MDUs with a wireless to BPL solution or something.
Anyways I just wanted to tell the other WISP folks out there that private small business still gives the corp industry a run for their money.
Remember that we are smarter and more effective then the big guys they just have deeper pockets that make everything a struggle but they will never have the heart and the ability to adapt like we do. In fact I think at times the bigger corps see how the small ones are functioning; but only creative small business will ever survive. No one ever said this industry was easy but it is worth it; I at least think this.
-Sincerely,
DesertAdmin