Hi
I tried this now. It works technically, but unfortunately the throughput is miserable..
The strange thing is that the MT Bandwidth Test shows very decent numbers (1.5 Mbps + 1.5 Mbps = 3.0 Mbps total), but when I route my laptop through these routers to the Internet, I only get around 200 kbps throughput to the Internet. Needless to say, the throughput to Internet locally on the backbone network is very much better..
Is there a known explanation for this..?
My solution is to use one RB750 in each end, both running ROS4.11. On the client side there is a local LAN connected to ether1 and two ADSL 2/1 Mb modems connected to ether2ðer3. On the backbone side there is a LAN with fast Internet access connected to ether1.
Since the modems get dynamic IP from the client side provider, I configure the MTs to use PPTP to establish the connection and get known static IP-addresses, then EoIP on top of that to get interfaces that can be bonded, and then I create a bonding-interface to join the two eoip-interfaces. An IP-address is then assigned to the bonding-interface on the backbone-side, and this is used as the default gateway from the client side.
These are the main important configs;
Backbone side:
/ppp secret
add caller-id="" comment="" disabled=no limit-bytes-in=0 limit-bytes-out=0 local-address=10.3.1.1 name=tunnel1 password=password profile=default remote-address=\
10.3.1.11 routes="" service=pptp
add caller-id="" comment="" disabled=no limit-bytes-in=0 limit-bytes-out=0 local-address=10.3.1.2 name=tunnel2 password=password profile=default remote-address=\
10.3.1.12 routes="" service=pptp
/interface eoip
add arp=enabled comment="" disabled=no l2mtu=65535 mac-address=02:7E:02:59:90:1C mtu=1500 name=eoip-tunnel1 remote-address=10.3.1.11 tunnel-id=1
add arp=enabled comment="" disabled=no l2mtu=65535 mac-address=02:BA:17:DC:E7:65 mtu=1500 name=eoip-tunnel2 remote-address=10.3.1.12 tunnel-id=2
/interface bonding
add arp=enabled arp-interval=100ms comment="" disabled=no down-delay=0s lacp-rate=30secs link-monitoring=none mii-interval=100ms mode=balance-rr mtu=1500 name=\
bonding1 primary=none slaves=eoip-tunnel1,eoip-tunnel2 transmit-hash-policy=layer-2 up-delay=0s
/ip address
add address=10.4.1.1/24 broadcast=10.4.1.255 comment="" disabled=no interface=bonding1 network=10.4.1.0
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=[Internet gateway] scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=[Client side LAN] gateway=10.4.1.11 scope=30 target-scope=10
Client side:
/interface pptp-client
add add-default-route=no allow=mschap2 comment="" connect-to=a.b.c.d dial-on-demand=no disabled=no max-mru=1458 max-mtu=1458 mrru=disabled name=pptp-out1 \
password=password profile=default user=tunnel1
add add-default-route=no allow=mschap2 comment="" connect-to=a.b.c.d+1 dial-on-demand=no disabled=no max-mru=1458 max-mtu=1458 mrru=disabled name=pptp-out2 \
password=password profile=default user=tunnel2
add arp=enabled comment="" disabled=no l2mtu=65535 mac-address=02:5A:89:47:36:57 mtu=1458 name=eoip-tunnel1 remote-address=10.3.1.1 tunnel-id=1
add arp=enabled comment="" disabled=no l2mtu=65535 mac-address=02:67:B8:46:8C:0E mtu=1458 name=eoip-tunnel2 remote-address=10.3.1.2 tunnel-id=2
add arp=enabled arp-interval=100ms arp-ip-targets=10.4.1.1 comment="" disabled=no down-delay=0s lacp-rate=30secs link-monitoring=none mii-interval=100ms mode=\
balance-rr mtu=1458 name=bonding1 primary=none slaves=eoip-tunnel1,eoip-tunnel2 transmit-hash-policy=layer-2 up-delay=0s
/ip address
add address=10.2.7.2/24 broadcast=10.2.7.255 comment="" disabled=no interface=ether2 network=10.2.7.0
add address=10.2.9.2/24 broadcast=10.2.9.255 comment="" disabled=no interface=ether3 network=10.2.9.0
add address=10.4.1.11/24 broadcast=10.4.1.255 comment="" disabled=no interface=bonding1 network=10.4.1.0
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.4.1.1 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=a.b.c.d/32 gateway=10.2.7.1 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=a.b.c.d+1/32 gateway=10.2.9.1 scope=30 target-scope=10
I would be very grateful for feedback if someone has tried anything similar, or even has a theoretical idea for an explanation..?
Thanks