i have a similar setup with a spa3000.
based information in the manual and mostly
http://wiki.mikrotik.com/wiki/Bandwith_ ... _ADSL_link
#What i do is define two main queues called Download and Upload
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=7500k name=Download parent=ether2 priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=900k name=Upload parent=ether1 priority=8
# Mangle the different sources. Address 192.168.1.4 is the spa
# and 192.168.1.5 is my server for nzb and torrents.
# Note default all packages are marked with 'users' and
# afterwards i change the things i want to have other priorities.
/ip firewall mangle
add action=mark-connection chain=forward comment="" disabled=no \
new-connection-mark=users-con passthrough=yes src-address=\
192.168.1.0/24
add action=mark-packet chain=forward comment="" connection-mark=users-con \
disabled=no new-packet-mark=users passthrough=yes
add action=mark-connection chain=forward comment="" disabled=no \
new-connection-mark=voip-con passthrough=yes src-address=192.168.1.4
add action=mark-packet chain=forward comment="" connection-mark=voip-con \
disabled=no new-packet-mark=voip passthrough=yes
add action=mark-connection chain=forward comment="" disabled=no \
new-connection-mark=lp-con passthrough=yes src-address=192.168.1.5
add action=mark-packet chain=forward comment="" connection-mark=lp-con \
disabled=no new-packet-mark=lp passthrough=yes
# now setup the different queues. I have an 10Mb down by 1Mb up adsl line.
#
/queue type
add name=DSL-download kind=pcq pcq-classifier=dst-address
add name=DSL-upload kind=pcq pcq-classifier=src-address
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name=queue2 packet-mark=users parent=Download priority=4 \
queue=DSL-download
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name=queue4 packet-mark=users parent=Upload priority=4 queue=\
DSL-upload
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=100k \
max-limit=7500k name=voip-rx packet-mark=voip parent=Download priority=1 \
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=100k \
max-limit=900k name=voip-tx packet-mark=voip parent=Upload priority=1 \
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=7500k name=lp-rx packet-mark=lp parent=Download priority=8 \
queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=900k name=lp-tx packet-mark=lp parent=Upload priority=8 queue=\
default
This works for me. It is key that you make sure the limits are set correctly.
Anyone reading this suggestions or improvements (or even what the
heck are you doing) are welcome.