Page 1 of 1

move user from hotspot to PPPoE??

Posted: Mon Sep 06, 2010 11:00 am
by namo
I have RouterOS v4.11 currently have user in hotspot.

In PPP , I have created the same profiles names as the one in hotspot.

I want to create the same users(secrets) for PPP as the hotspot users (same user name, password and profile name).

Is there a command or a script to do that? OR I have to add each ppp user manually.

Re: move user from hotspot to PPPoE??

Posted: Mon Sep 06, 2010 11:11 am
by mrz
you can create a script, something like below

:foreach i in=[/ip hotspot user find] do={
/ppp secret add name=[/ip hotspot user get $i name] password=[/ip hotspot user get $i password];
}

Re: move user from hotspot to PPPoE??

Posted: Mon Sep 06, 2010 11:32 am
by namo
you can create a script, something like below

:foreach i in=[/ip hotspot user find] do={
/ppp secret add name=[/ip hotspot user get $i name] password=[/ip hotspot user get $i password];
}
this will add the users in the defaulted ppp profile not the same profile

Re: move user from hotspot to PPPoE??

Posted: Mon Sep 06, 2010 11:39 am
by namo
I did this and worked
:foreach i in=[/ip hotspot user find] do={
/ppp secret add name=[/ip hotspot user get $i name] password=[/ip hotspot user get $i password] profile=[/ip hotspot user get $i profile] comment=[/ip hotspot user get $i comment];
}