Hi bombato,
okay this is what you have to do
let's say that your LAN has the network address of 192.168.1.0/24
what you have to do is to create a mangle rule to mark the connection and packet to this network, and then mark connection and packet for everything that isn't the network, then apply a queue for each one of the packets...this is an example
/ip firewall mangle add chain=prerouting dst-address=192.168.1.0/24 action=mark-connection new-connection-mark=LAN
/ip firewall mangle add chain=prerouting connection-mark=LAN action=mark-packet new-packet-mark=LAN-pack
/ip firewall mangle add chain=prerouting dst-address=!192.168.1.0/24 action=mark-connection new-connection-mark=WAN
/ip firewall mangle add chain=prerouting connection-mark=WAN action=mark-packet new-packet-ark=WAN-pack
/queue simple add name=Limit-LAN limit-at=1024000/1024000 max-limit=1024000/1024000 packet-marks=LAN-pack
/queue simple add name=Limit-WAN limit-at=512000/512000 max-limit=512000/512000 packet-marks=WAN-pack
ok now what this means is that...
first you mark a connection with every connection with destination address of 192.168.1,0/24 and mark it, then take that connection and mark the packets of that connection
second you mark a connection with every connection that has NOT destination address of 192.168.1,0/24 (which means NOT LAN) and mark it, then take that connection and mark the packets of that connection
Then apply a queue for the LAN of 1Mbps and 512kbps for WAN...
if you need any further explanation let me know
regards