Hi all,
i have a configuration created (combined from different sources such as the wiki, forum posts, ...) that seems to work quite well. I would however like to get feedback if it is indeed as it should be. Also it could help out others.
The next section is mangle and queue section. Any comments ?
Additional information. It is a home network with an ADSL (10000/1024) connection. I have a voip ata at 192.168.179.4, a WHS server at 192.168.179.5 and a NAS at 192.168.179.8
Tinka.
/ip firewall mangle
add action=mark-connection chain=forward comment="" connection-state=new disabled=no new-connection-mark=users-con passthrough=yes src-address=192.168.179.0/24
add action=mark-connection chain=forward comment="" connection-state=new disabled=no dst-address=192.168.179.0/24 new-connection-mark=users-con passthrough=yes
add action=mark-connection chain=forward comment="" connection-state=new disabled=no new-connection-mark=voip-con passthrough=yes src-address=192.168.179.4
add action=mark-connection chain=forward comment="" connection-state=new disabled=no dst-address=192.168.179.4 new-connection-mark=voip-con passthrough=yes
add action=mark-connection chain=forward comment="" connection-state=new disabled=no new-connection-mark=lp-con passthrough=yes src-address=192.168.179.5
add action=mark-connection chain=forward comment="" connection-state=new disabled=no new-connection-mark=lp-con passthrough=yes src-address=192.168.179.8
add action=mark-connection chain=forward comment="" connection-state=new disabled=no dst-address=192.168.179.5 new-connection-mark=lp-con passthrough=yes
add action=mark-connection chain=forward comment="" connection-state=new disabled=no dst-address=192.168.179.8 new-connection-mark=lp-con passthrough=yes
add action=mark-packet chain=forward comment="" connection-mark=users-con disabled=no new-packet-mark=users passthrough=no
add action=mark-packet chain=forward comment="" connection-mark=voip-con disabled=no new-packet-mark=voip passthrough=yes
add action=change-dscp chain=forward comment="" connection-mark=voip-con disabled=no new-dscp=1
add action=mark-packet chain=forward comment="" connection-mark=lp-con disabled=no new-packet-mark=lp passthrough=no
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=8M name=Download parent=ether2 priority=8
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=900k name=Upload parent=ether1 priority=8
/queue type
set default kind=pfifo name=default pfifo-limit=50
set ethernet-default kind=pfifo name=ethernet-default pfifo-limit=50
set wireless-default kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set synchronous-default kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 red-limit=60 red-max-threshold=50 \
red-min-threshold=10
set hotspot-default kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
add kind=pcq name=DSL-download pcq-classifier=dst-address pcq-limit=50 pcq-rate=0 pcq-total-limit=2000
add kind=pcq name=DSL-upload pcq-classifier=src-address pcq-limit=50 pcq-rate=0 pcq-total-limit=2000
set default-small kind=pfifo name=default-small pfifo-limit=10
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=queue2 packet-mark=users parent=Download \
priority=4 queue=DSL-download
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=queue4 packet-mark=users parent=Upload \
priority=4 queue=DSL-upload
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=100k max-limit=8M name=voip-rx packet-mark=voip parent=\
Download priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=100k max-limit=900k name=voip-tx packet-mark=voip parent=\
Upload priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=8M name=lp-rx packet-mark=lp parent=Download \
priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=900k name=lp-tx packet-mark=lp parent=Upload \
priority=8 queue=default
/queue interface
set ether1 queue=ethernet-default
set ether2 queue=ethernet-default
set ether3 queue=ethernet-default
set ether4 queue=ethernet-default
set ether5 queue=ethernet-default
set MyPPPoE queue=default