Page 1 of 1

interrupted - invalid internal item number

Posted: Wed Jan 26, 2011 2:23 pm
by awayand
Hello there,
I am trying to use the everydns script found here:
http://wiki.mikrotik.com/wiki/Dynamic_D ... r_EveryDNS

but when I run it, I get the following error:
[admin@router] /system script> run everydns
interrupted
           invalid internal item number
Any ideas?

Re: interrupted - invalid internal item number

Posted: Wed Jan 26, 2011 11:19 pm
by SurferTim
What do you have set for the interface name?
:local edinterface "INTERFACE_NAME"
That might cause an error if not correct.

Re: interrupted - invalid internal item number

Posted: Thu Jan 27, 2011 12:25 am
by awayand
thanks for the hint. In keeping things simple, I kept the pre-configured name, so my config reads:
:local edinterface "ether1"
Any other ideas? How can I "debug" this script? Copy/pasting the entire script into the terminal?

Re: interrupted - invalid internal item number

Posted: Thu Jan 27, 2011 1:24 pm
by SurferTim
The "internal item number" is normally gotten from a "find" command, like
:local edip [ /ip address get [/ip address find interface=$edinterface ] address ]
or
:local str [/file find name="EveryDNS.$eddomain"];
I use a ":put" command to debug, but it only works when the script is run from the command line. It won't work with the scheduler. Try adding a couple lines like this:
:put "made it here";
I would put one of these immediately after each of those two statements and run it. See where it displays the "internal item number" error in relation to "made it here".

Re: interrupted - invalid internal item number

Posted: Mon Jul 29, 2013 2:38 pm
by kaas
Use

:global ddnsip [ /ip address get [find interface=$ddnsinterface disabled=no] address ]