/ip address print detail
Flags: X - disabled, I - invalid, D - dynamic
0 address=192.168.0.254/24 network=192.168.0.0 broadcast=192.168.0.255 interface=lan actual-interface=lan
1 D address=192.168.1.10/24 network=192.168.1.0 broadcast=192.168.1.255 interface=wan actual-interface=wan
/ip route print detail
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
0 ADS dst-address=0.0.0.0/0 gateway=192.168.1.1 interface=wan gateway-state=reachable distance=0 scope=30 target-scope=10
1 ADC dst-address=192.168.0.0/24 pref-src=192.168.0.254 interface=lan distance=0 scope=10
2 ADC dst-address=192.168.1.0/24 pref-src=192.168.1.10 interface=wan distance=0 scope=10
/interface print
Flags: D - dynamic, X - disabled, R - running, S - slave
# NAME TYPE MTU L2MTU
0 R wan ether 1500
1 R lan
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=10s \
tcp-last-ack-timeout=10s tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m \
udp-timeout=10s
/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no
http://192.168.0.18
Also in the client's browser settings?i got a proxy id in the request heade , although the http proxy is disabled !!
I am experiencing this too, and i have looked around and still can't figure out why this is happening. I observe this started from V4.12. So i will like to hear how you got around this. Thanksuser connects using the ip addressbut on the HFS server the connection shows the request source is 192.168.0.254 which is the "mikrotik ip"Code: Select allhttp://192.168.0.18
the users ip is 192.168.0.x
and the HFS is 192.168.0.18
Thanks for the prompt reply, yeah i have it set to none, but i am still experiencing the problem. I have 7 VLANs and it still show that the traffic is originating from the gateway of one of the VLANs.Maybe the Hotspot is ARP poisoning the network because of a Universal NAT address pool.
Do you have an address pool configured under the "/ip hotspot" instance tied to the interface you're experiencing this on? If yes, try setting it to 'none', flush the ARP caches of the clients you're testing with (when in doubt reboot them) and then try again.
The server is on say VLAN2 with subnet 172.2.0.0/21 and gateway 172.2.0.1 (mikrotik ip)Is the server you're trying to access in the same broadcast domain as the clients accessing it, or is the traffic being routed between two networks?
This is actually not different from what the other person raised, the only difference is i have Vlans. Even if i access the server from within the VLAN2 subnet it still report on the hfs that its from 172.2.0.1 which is the router gateway address. Out interface did not work either.Your case is completely different from what the original poster experienced. He had same subnet traffic affected.
You just have a source NAT rule that is too broad and NATs traffic between all interfaces instead of just out to the Internet.
At a wild stab without seeing your config, first determine the name of the interface that connects you to the Internet. Let's assume it's called "WAN". Then find the rule in the src-nat chain that has an action of 'masquerade', edit it, and add 'out-interface=WAN'.
If you need further help with that post the output of "/ip address print detail", "/interface print detail", "/ip route print detail", and "/ip firewall nat export".
Hey it seems its working! but its quite starnge in that i usually don't have this problem when using V4.11. So i had to no specify out interface for each of the subnet and that did the trick! Now because i have multiple out interfaces, i may have to do for each of the subnets for other out interfaces.Please post the output of the commands I requested, and add "/interface ethernet print detail" and "/interface vlan print detail".
/ip firewall nat add chain=srcnat out-interface=WAN action=masquerade
Thats actually not a real ip, just typed something for illustration. Yeah i summarized it. ThanksThe NAT rules can usually be reduced to just one that covers all attached networks, and does to only for WAN traffic. It should look something like this:
The Hotspot wizards add all kinds of rules that reference the specific IP space, that can be simplified manually.Code: Select all/ip firewall nat add chain=srcnat out-interface=WAN action=masquerade
Also, just on a sidenote, 172.2.0.1/21 is not private IP space. You may run into problems with that further down the road.
/ip firewall nat
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=10.0.0.2 \
dst-port=80 protocol=tcp to-addresses=50.60.70.100 to-ports=80
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=10.0.0.2 \
dst-port=80 protocol=udp to-addresses=50.60.70.100 to-ports=80
/ip firewall mangle
add action=mark-packet chain=prerouting comment=ShareUpLoad disabled=no dst-port=80 \
new-packet-mark=ShareUpLoad passthrough=no protocol=tcp
add action=mark-packet chain=postrouting comment=ShareDownLoad disabled=no \
new-packet-mark=ShareDownLoad passthrough=no protocol=tcp src-port=80
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name=ShareUpLoad packet-mark=ShareUpLoad parent=global-in \
priority=6 queue=ethernet-default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name=ShareDownLoad packet-mark=ShareDownLoad parent=\
global-out priority=6 queue=ethernet-default