RB to RB VPLS tunnel MTU trouble
Posted: Sat Mar 19, 2011 12:55 am
Hello,
We are trying to transition from EoIP to VPLS tunnels.
Having a VPLS MTU issue, not sure if my settings are correct. I have the following setup (see below.) When I try to do a speedtest through the tunnel it fails after it connects unless I set it to UDP and reduce the packet size down to 1482, then it will perform. Same with pinging the remote side, anything bigger than 1482 fails. I am stumped on how to address the various MTU settings. My assumption is that I should be able to do 1500byte pings through that VPLS.
I intentionally reduced the Testbench to rule out radios.
Thanks,
--Christian
router1: routermaxx 1200 v5.0rc11: ethernet: l2mtu=<blank> mtu=1500
router 2: powerrouter 732 v5.0rc11: ethernet: l2mtu=1600 mtu=1500
We are trying to transition from EoIP to VPLS tunnels.
Having a VPLS MTU issue, not sure if my settings are correct. I have the following setup (see below.) When I try to do a speedtest through the tunnel it fails after it connects unless I set it to UDP and reduce the packet size down to 1482, then it will perform. Same with pinging the remote side, anything bigger than 1482 fails. I am stumped on how to address the various MTU settings. My assumption is that I should be able to do 1500byte pings through that VPLS.
I intentionally reduced the Testbench to rule out radios.
Thanks,
--Christian
Code: Select all
router1 <------1gig ethernet full duplex-----> router2
Code: Select all
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
add disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=yes hop-limit=255 loop-detect=no lsr-id=1.0.0.255 \
path-vector-limit=255 transport-address=1.0.0.255 use-explicit-null=no
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s interface=ether8_vpls_tep \
transport-address=0.0.0.0
/interface vpls
add advertised-l2mtu=1500 arp=enabled cisco-style=no cisco-style-id=0 disable-running-check=no disabled=no \
l2mtu=1500 mac-address=02:80:42:8E:2F:95 mtu=1500 name=vpls-test pw-type=raw-ethernet remote-peer=\
1.0.0.253 vpls-id=253:253
/ip address
add address=10.10.12.4/24 disabled=no interface=vpls-test network=10.10.12.0
Code: Select all
/mpls
set dynamic-label-range=16-1048575 propagate-ttl=yes
/mpls interface
add disabled=no interface=all mpls-mtu=1508
/mpls ldp
set distribute-for-default-route=no enabled=yes hop-limit=255 loop-detect=no \
lsr-id=1.0.0.253 path-vector-limit=255 transport-address=1.0.0.253 \
use-explicit-null=no
/mpls ldp interface
add accept-dynamic-neighbors=yes disabled=no hello-interval=5s hold-time=15s \
interface=ether1-core transport-address=0.0.0.0
/interface vpls
add advertised-l2mtu=1500 arp=enabled cisco-style=no cisco-style-id=0 \
disable-running-check=no disabled=no l2mtu=1500 mac-address=\
02:2C:1E:B8:EB:EC mtu=1500 name=vpls-test pw-type=raw-ethernet remote-peer=\
1.0.0.255 vpls-id=253:253
/ip address
add address=10.10.12.5/24 disabled=no interface=vpls-test network=10.10.12.0