That looks about right. How are you testing? Where is the test machine located in relation to the target server? Also, post the output of "/ip address print detail", "/ip route print detail", "/interface print", "/ip firewall export", and an accurate network diagram.
Hi Fewi,
I try with
http://222.124.139.aaa:8081 with my PC (192.168.0.21)
if i try like this
http://192.168.0.252:8081 it can access the web server
[ptpm@PTPM] /ip address> print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 192.168.0.1/24 192.168.0.0 192.168.0.255 Local
1 222.124.139.xxx/29 222.124.139.yyy 222.124.139.zzz Internet
[ptpm@PTPM] /ip route> print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 A S 0.0.0.0/0 222.124.139.193 1
1 ADC 192.168.0.0/24 192.168.0.1 Local 0
2 ADC 222.124.139.xxx/29 222.124.139.aaa Internet 0
[ptpm@PTPM] /interface> print
Flags: D - dynamic, X - disabled, R - running, S - slave
# NAME TYPE MTU L2MTU
0 R Internet ether 1500 1526
1 R Local ether 1500 1524
2 ether3 ether 1500 1524
3 ether4 ether 1500 1524
4 ether5 ether 1500 1524
[ptpm@PTPM] /ip firewall> export
# jun/14/2011 14:39:06 by RouterOS 4.10
# software id = G4R8-KFHV
#
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d \
tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=accept chain=input comment="Added by webbox" disabled=no protocol=\
icmp
add action=accept chain=input comment="Added by webbox" connection-state=\
established disabled=no in-interface=Internet
add action=accept chain=input comment="Added by webbox" connection-state=\
related disabled=no in-interface=Internet
add action=drop chain=input comment="Added by webbox" disabled=no \
in-interface=Internet
add action=jump chain=forward comment="Added by webbox" disabled=no \
in-interface=Internet jump-target=customer
add action=accept chain=customer comment="Added by webbox" connection-state=\
established disabled=no
add action=accept chain=customer comment="Added by webbox" connection-state=\
related disabled=no
add action=drop chain=customer comment="Added by webbox" disabled=no
/ip firewall mangle
add action=mark-packet chain=output comment="Hit Traffic From Proxy" \
disabled=no dscp=4 new-packet-mark=Proxy-Hit out-interface=Local \
passthrough=no
add action=mark-packet chain=prerouting comment="Up Traffic" disabled=no \
in-interface=Local new-packet-mark=Test-Up passthrough=no src-address=\
192.168.0.0/24
add action=mark-connection chain=forward comment="Mark Conn" disabled=no \
new-connection-mark=Test-Conn passthrough=yes src-address=192.168.0.0/24
add action=mark-packet chain=forward comment=Down-Direct connection-mark=\
Test-Conn disabled=no in-interface=Internet new-packet-mark=Test-Down \
passthrough=no
add action=mark-packet chain=output comment="Down-Via Proxy" disabled=no \
dst-address=192.168.0.0/24 new-packet-mark=Test-Down out-interface=Local \
passthrough=no
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
add action=redirect chain=dstnat comment="" disabled=no dst-port=80 \
in-interface=Local protocol=tcp src-address=192.168.0.0/24 to-ports=8080
add action=redirect chain=dstnat comment="" disabled=no dst-port=3128 \
in-interface=Local protocol=tcp src-address=192.168.0.0/24 to-ports=8080
add action=redirect chain=dstnat comment="" disabled=no dst-port=8000 \
in-interface=Local protocol=tcp src-address=192.168.0.0/24 to-ports=8080
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
disabled=no src-address=222.124.139.xxx/29
add action=masquerade chain=srcnat comment="Added by webbox" disabled=no \
out-interface=Internet
add action=dst-nat chain=dstnat comment="" disabled=no dst-address=\
222.124.139.aaa dst-port=8081 protocol=tcp to-addresses=192.168.0.252 \
to-ports=8081
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no
diagram : Internet - Modem - Mikrotik - Switch - User, Web server
Thanks,