Hi Fewi.
Thanks for the response. Would just like to try and figure why this is not working. I striped it down to the very basic. If i can get this running the rest should just be copy and paste. Attached a schematic. I created two PPPoE client on router 2 connecting through the Vlans and the respective modems to the internet. This setup is purely to test the best setup to route traffic through the respective PPPoE connections, which of cause , i cant seem to get running. First of i ping website on internet from router 1 with mangle rules disabled, this functions correct. Then i enable mangle rules to route traffic from router 1 through PPPoE 2 instead of PPPoE 1. Not able to ping site any more. Must be missing something.
ip address print
Flags: X - disabled, I - invalid, D - dynamic
# ADDRESS NETWORK INTERFACE
0 193.168.125.10/24 193.168.125.0 ether2
1 D 196.209.237.52/32 41.242.12.1 PPPoE Day 1
2 D 196.209.237.80/32 41.242.12.1 PPPoE Day 2
/ip route
add comment="Route 1 " disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
"PPPoE Day 1" routing-mark=Route_1_out scope=30 target-scope=10
add comment="Route 2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
"PPPoE Day 2" routing-mark=Route_2_out scope=30 target-scope=10
add comment="Default Gateway" disabled=no distance=1 dst-address=0.0.0.0/0 \
gateway="PPPoE Day 1" scope=30 target-scope=10
ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=srcnat action=masquerade out-interface=PPPoE Day 1
1 chain=srcnat action=masquerade out-interface=PPPoE Day 2
/ip route
add comment="Route 1 " disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
"PPPoE Day 1" routing-mark=Route_1_out scope=30 target-scope=10
add comment="Route 2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
"PPPoE Day 2" routing-mark=Route_2_out scope=30 target-scope=10
add comment="Default Gateway" disabled=no distance=1 dst-address=0.0.0.0/0 \
gateway="PPPoE Day 1" scope=30 target-scope=10
/interface ethernet
set 0 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=\
no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:3D:F4:48 master-port=\
none mtu=1500 name=ether1 speed=100Mbps
set 1 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment=\
"From Router 1" disabled=no full-duplex=yes l2mtu=1524 mac-address=\
00:0C:42:3D:F4:49 master-port=none mtu=1500 name=ether2 speed=100Mbps
set 2 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=\
no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:3D:F4:4A master-port=\
none mtu=1500 name=ether3 speed=100Mbps
set 3 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited comment=\
"To Switch" disabled=no full-duplex=yes l2mtu=1524 mac-address=\
00:0C:42:3D:F4:4B master-port=none mtu=1500 name=ether4 speed=100Mbps
set 4 arp=enabled auto-negotiation=yes bandwidth=unlimited/unlimited disabled=\
no full-duplex=yes l2mtu=1524 mac-address=00:0C:42:3D:F4:4C master-port=\
none mtu=1500 name=ether5 speed=100Mbps
/interface vlan
add arp=enabled disabled=no interface=ether4 l2mtu=1520 mtu=1500 name=vlan1 \
use-service-tag=no vlan-id=10
add arp=enabled disabled=no interface=ether4 l2mtu=1520 mtu=1500 name=vlan2 \
use-service-tag=no vlan-id=20
/interface pppoe-client
add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=Day \
dial-on-demand=no disabled=no interface=vlan1 max-mru=1480 max-mtu=1480 \
mrru=disabled name="PPPoE Day 1" password=obytyhzz profile=default \
service-name="" use-peer-dns=no user=isp0080@isdsl.net
add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment=Day \
dial-on-demand=no disabled=no interface=vlan2 max-mru=1480 max-mtu=1480 \
mrru=disabled name="PPPoE Day 2" password=ATJeMAky profile=default \
service-name="" use-peer-dns=no user=isp71541@dsl512.isdsl.net
/interface ethernet switch
set switch1 mirror-source=none mirror-target=none name=switch1 \
switch-all-ports=yes
/interface wireless security-profiles
set default authentication-types="" eap-methods=passthrough group-ciphers="" \
group-key-update=5m interim-update=0s management-protection=disabled \
management-protection-key="" mode=none name=default radius-eap-accounting=\
no radius-mac-accounting=no radius-mac-authentication=no \
radius-mac-caching=disabled radius-mac-format=XX:XX:XX:XX:XX:XX \
radius-mac-mode=as-username static-algo-0=none static-algo-1=none \
static-algo-2=none static-algo-3=none static-key-0="" static-key-1="" \
static-key-2="" static-key-3="" static-sta-private-algo=none \
static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=\
MikroTik tls-certificate=none tls-mode=no-certificates unicast-ciphers="" \
wpa-pre-shared-key="" wpa2-pre-shared-key=""
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no
/interface ethernet switch port
set ether1 vlan-header=leave-as-is vlan-mode=fallback
set ether2 vlan-header=leave-as-is vlan-mode=fallback
set ether3 vlan-header=leave-as-is vlan-mode=fallback
set ether4 vlan-header=leave-as-is vlan-mode=fallback
set ether5 vlan-header=leave-as-is vlan-mode=fallback
set switch1_cpu vlan-header=leave-as-is vlan-mode=fallback
/interface l2tp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=default-encryption \
enabled=no max-mru=1460 max-mtu=1460 mrru=disabled
/interface ovpn-server server
set auth=sha1,md5 certificate=none cipher=blowfish128,aes128 default-profile=\
default enabled=no keepalive-timeout=60 mac-address=FE:3B:AF:6D:1B:7A \
max-mtu=1500 mode=ip netmask=24 port=1194 require-client-certificate=no
/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=default-encryption enabled=\
no keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled
/interface sstp-server server
set authentication=pap,chap,mschap1,mschap2 certificate=none default-profile=\
default enabled=no keepalive-timeout=60 max-mru=1500 max-mtu=1500 mrru=\
disabled port=443 verify-client-certificate=no
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=\
00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 frame-size=300 \
frames-per-second=25 receive-all=no ssid-all=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 \
multiple-channels=no only-headers=no receive-errors=no streaming-enabled=no \
streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
You do not have the required permissions to view the files attached to this post.