Page 1 of 1

Combine 2 ISP speed

Posted: Wed Feb 08, 2012 12:40 am
by arsenm
Hi I have 2 ISP providers
wan1-20mbps
wan2-6mbps
I need to combine 2 WAN's and have speed on LAN 26Mb
How can I do it ?
I tried:

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8,8.8.8.8

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
-----------------------------------------------------------------------
but no success
summary my speed 20mbps

Re: Combine 2 ISP speed

Posted: Wed Feb 08, 2012 9:15 pm
by eszaknet
I think you mark the connections in bad chains. Try to use prerouting chain instead of input and output.

Re: Combine 2 ISP speed

Posted: Thu Feb 09, 2012 10:43 pm
by javedshotline
/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2


/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2


/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2

/ip firewall nat
add chain=srcnat action=masquerade



Remember you haven't set default gateway & gateway for your local network.
here we go
First Mark Lan traffic with mangle rule
/ip firewall mangle
add chain=prerouting src-address=192.168.0.0/24 action=mark-routing new-routing-mark=local_trafic
Now add gateway for local trafic
/ip route
add dst-address=0.0.0.0/0 gateway="192.168.1.1,192.168.2.1,192.168.1.1,192.168.1.1" routing-mark=local_trafic
i have added 192.168.1.1 for 3 times & 192.168.2.1 for 1 time for automatic load balancing. as ur first gateway has 20Mbps & second has 6Mbps
now add default gateway, remember web proxy & dns requests goes through this gateway

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 or 192.168.2.1 use which is more reliable


i hope this info will helpfull for you!

Re: Combine 2 ISP speed

Posted: Fri Feb 10, 2012 3:31 am
by MCT
Just a note that if you load balance a 20mpbs connection and a 6mbps connection you don't combine the speeds. Those connections will be the same speed you'll just have the load spread among them. The only way to get a 26mbps connection out of that is interface bonding and that requires the ISPs cooperation because they have to bond on their end as well.

Re: Combine 2 ISP speed

Posted: Fri Feb 10, 2012 4:52 pm
by javedshotline
Just a note that if you load balance a 20mpbs connection and a 6mbps connection you don't combine the speeds. Those connections will be the same speed you'll just have the load spread among them. The only way to get a 26mbps connection out of that is interface bonding and that requires the ISPs cooperation because they have to bond on their end as well.
And that is not an easy job

Re: Combine 2 ISP speed

Posted: Sat Feb 11, 2012 12:41 am
by arsenm
thank you for help, guys

Re: Combine 2 ISP speed

Posted: Thu Apr 28, 2016 3:30 am
by cyberjhep
/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2


/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2


/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2

/ip firewall nat
add chain=srcnat action=masquerade



Remember you haven't set default gateway & gateway for your local network.
here we go
First Mark Lan traffic with mangle rule
/ip firewall mangle
add chain=prerouting src-address=192.168.0.0/24 action=mark-routing new-routing-mark=local_trafic
Now add gateway for local trafic
/ip route
add dst-address=0.0.0.0/0 gateway="192.168.1.1,192.168.2.1,192.168.1.1,192.168.1.1" routing-mark=local_trafic
i have added 192.168.1.1 for 3 times & 192.168.2.1 for 1 time for automatic load balancing. as ur first gateway has 20Mbps & second has 6Mbps
now add default gateway, remember web proxy & dns requests goes through this gateway

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 or 192.168.2.1 use which is more reliable


i hope this info will helpfull for you!
-----------
ty this sir this maybe help me

Re: Combine 2 ISP speed

Posted: Fri Aug 03, 2018 9:23 am
by anthonyl1981
/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2


/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2


/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2

/ip firewall nat
add chain=srcnat action=masquerade



Remember you haven't set default gateway & gateway for your local network.
here we go
First Mark Lan traffic with mangle rule
/ip firewall mangle
add chain=prerouting src-address=192.168.0.0/24 action=mark-routing new-routing-mark=local_trafic
Now add gateway for local trafic
/ip route
add dst-address=0.0.0.0/0 gateway="192.168.1.1,192.168.2.1,192.168.1.1,192.168.1.1" routing-mark=local_trafic
i have added 192.168.1.1 for 3 times & 192.168.2.1 for 1 time for automatic load balancing. as ur first gateway has 20Mbps & second has 6Mbps
now add default gateway, remember web proxy & dns requests goes through this gateway

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 or 192.168.2.1 use which is more reliable


i hope this info will helpfull for you!
This is helpfull