traffic identification for queue misbehaving
Posted: Fri Feb 10, 2012 7:03 pm
So I've got this router...
It sits at (let's say) 192.168.100.230. We have assigned a block to them of 192.168.100.80/29. I'm trying to build a single queue which encompasses all traffic flowing from that customer's location. The solution I had devised to accomplish this was to mark packets with mangle and queue based on the packet mark.
Here's what the mangle rules look like:
I just threw in a simple queue to limit all traffic marked with "cust_pkt" to 20M up and 20M down. The queue is getting hit, but the Rx Avg. Rate and Tx Avg Rate are identical. I can't figure out what the logic is behind this and where my flaw lies. Any ideas?
It sits at (let's say) 192.168.100.230. We have assigned a block to them of 192.168.100.80/29. I'm trying to build a single queue which encompasses all traffic flowing from that customer's location. The solution I had devised to accomplish this was to mark packets with mangle and queue based on the packet mark.
Here's what the mangle rules look like:
Code: Select all
/ip firewall mangle
add action=mark-connection chain=prerouting disabled=no new-connection-mark=\
cust_conn passthrough=yes src-address=192.168.100.230
add action=mark-connection chain=prerouting disabled=no dst-address=\
192.168.100.230 new-connection-mark=cust_conn passthrough=yes
add action=mark-connection chain=prerouting disabled=no new-connection-mark=\
cust_conn passthrough=yes src-address=192.168.100.80/29
add action=mark-connection chain=prerouting disabled=no dst-address=\
192.168.100.80/29 new-connection-mark=cust_conn passthrough=yes
add action=mark-packet chain=prerouting connection-mark=cust_conn disabled=no \
new-packet-mark=cust_pkt passthrough=no