Hi I have some problem with situation below:
ether1 - ISP1, IP: A.A.A.A/30
ether2 - ISP2, IP: B.B.B.B/30
ether3 - lan IP: 192.168.0.1/16 and C.C.C.1/24 and pool of external IPs from provider ISP2
I would like to use internet from provider ISP1 for computers from range 192.168.0.0/16 (NAT) and internet from provider ISP2 for computers with external IP.
my config:
/ip firewall mangle
add action=mark-routing chain=prerouting comment="" disabled=no \
new-routing-mark=to_ISP1 passthrough=no src-address=192.168.0.0/16
add action=mark-routing chain=prerouting comment="" disabled=no \
new-routing-mark=to_ISP2 passthrough=no src-address=C.C.C.0/24
/ip route
add comment="ISP1" disabled=no distance=1 dst-address=0.0.0.0/0 \
gateway=A.A.A.1 routing-mark=to_ISP1 scope=30 target-scope=10
add comment="ISP2" disabled=no distance=1 dst-address=0.0.0.0/0 \
gateway=B.B.B.49 routing-mark=to_ISP2 scope=30 target-scope=10
/ip firewall nat
add action=masquerade chain=srcnat comment=nat disabled=no \
src-address=192.168.0.0/16
please helt because with this config nothing works.
Misha