Community discussions

MikroTik App
 
User avatar
Charlie Whiskey
just joined
Topic Author
Posts: 24
Joined: Wed Nov 16, 2005 7:45 am

A firewall question (UDP and connection state / tracking)

Wed Jan 04, 2006 3:27 am

I'm still a firewall scripting beginner so please bear with me. I have the following requirements:

1) Allow the router to request NTP synchronisation with an external time source.
2) Allow computers on the LAN segment to request NTP synchronisation with this router.
3) Drop all other synchronisation requests.

Can somebody help me with writing the firewall rules?
 
smilga
just joined
Posts: 17
Joined: Wed Jun 02, 2004 3:10 pm

Wed Jan 04, 2006 3:01 pm

/ip firewall filter add action=accept src-port=123 protocol=udp src-address=x.y.z.a chain=input comment="Allow the router to request NTP synchronisation with an external time source"
/ip firewall filter add action=accept dst-port=123 protocol=udp in-interface=local chain=input comment="Allow computers on the LAN segment to request NTP synchronisation with this router"
/ip firewall filter add action=drop dst-port=123 protocol=udp chain=input comment="Drop all other synchronisation requests"
/ip firewall filter add action=drop src-port=123 protocol=udp chain=input comment="Drop all other synchronisation requests"
/ip firewall filter add action=drop dst-port=123 protocol=udp chain=forward comment="Drop all other synchronisation requests"


I suggest you also look at this example:
http://www.mikrotik.com/docs/ros/2.9/ip ... t#6.38.3.1

Who is online

Users browsing this forum: lele, mitchellhenry, starcake, tuiespacecorp, vic666 and 93 guests