it use the ND feture. just put win 7 in auto, put an ipv6 subnet on the interface pointing to your win7 machine, and its all auto.
Mine ipv6 at home (isp dont provide ipv6)
a sit interface to hurricane. give me a /64. And a routed /48 (just for fun)
then add one subnet to the interface that have yur ipv4 addresses (typicly where nat is done)
enable advertise=yes and ND (i think its default)
my config:
/ipv6 address
add address=2001:470:xxxx:623::2/64 advertise=no disabled=no eui-64=no \
interface=sit1
add address=2001:470:xxxx::1/48 advertise=no disabled=no eui-64=no interface=\
sit1
add address=2001:470:xxxx:3::1/64 advertise=no disabled=no eui-64=no \
interface=l2tp-bridge
add address=2001:470:xxxx:2::1/64 advertise=yes disabled=no eui-64=no \
interface=bridge
/ipv6 firewall mangle
add action=change-mss chain=forward disabled=no in-interface=sit1 new-mss=\
1240 passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1241-65535
add action=change-mss chain=forward disabled=no new-mss=1240 out-interface=\
sit1 passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1241-65535
/ipv6 nd
set [ find default=yes ] advertise-dns=yes advertise-mac-address=yes \
disabled=no hop-limit=64 interface=bridge managed-address-configuration=\
no mtu=unspecified other-configuration=yes ra-delay=3s ra-interval=\
3m20s-10m ra-lifetime=30m reachable-time=unspecified retransmit-interval=\
unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:xxxx:623::1 \
scope=30 target-scope=10