One question, are you just forwarding the traffic on these vlans through the interfaces or do you need to route from ether1/ether2 to ether3? If I understand you right you're just forwarding the traffic?
If that is the case then this scenario should work for you:
/interface ethernet switch port
set 0 vlan-header=always-strip vlan-mode=secure
set 1 vlan-header=always-strip vlan-mode=secure
set 2 vlan-header=add-if-missing vlan-mode=secure
/interface ethernet switch rule
add new-dst-ports=ether1 ports=ether3 switch=switch1 vlan-header=present vlan-id=1
add new-dst-ports=ether2 ports=ether3 switch=switch1 vlan-header=present vlan-id=2
add new-dst-ports=ether3 new-vlan-id=1 ports=ether1 switch=switch1 vlan-header=not-present
add new-dst-ports=ether3 new-vlan-id=2 ports=ether2 switch=switch1 vlan-header=not-present
This is not enough, we have to pass the traffic through and tag the packets:
/interface ethernet switch vlan
add ports=ether3 switch=switch1 vlan-id=1
add ports=ether3 switch=switch1 vlan-id=2
add ports=ether1,ether2 switch=switch1 vlan-id=0
This last line seems to be needed for things to work. This kind of "bridges" the vlans between these interfaces, it does no routing. The vlans are, or should be, completely seperated this way.