I have a RB450 (updated to RouterOS 5.20)
2 LANs (172.16.1.0/24 (Main LAN) and 172.16.99.0/24 (Other LAN))
I would like the machines on the two LANs to be able to connect to each other through the router.
I have done a factory reset of the routerboard using winbox and the first time I connect I have said don't do the default config (I have also tried letting it do the default config).
Then added the two interface addresses:
Code: Select all
/ip address
add address=172.16.1.251/24 comment="Main LAN" disabled=no interface=\
ether2 network=172.16.1.0
/ip address
add address=172.16.99.251/24 comment="Second LAN" disabled=no interface=\
ether5 network=172.16.99.0
Code: Select all
/ip firewall filter add action=accept chain=forward in-interface=ether2
/ip firewall filter add action=accept chain=forward in-interface=ether5
Then plugged a network cable into ports eth2 and eth5 of the routerboard from the respective network switches.
on a machine (172.16.1.141) on the 172.16.1.x network I have added a route
route add 172.16.99.0 mask 255.255.255.0 172.16.1.251
on a machine (172.16.99.20) on the 172.16.99.x network I have added a route
route add 172.16.1.0 mask 255.255.255.0 172.16.99.251
from the machine (172.16.1.141) on the 172.16.1.x network I can ping 172.16.99.151 (the other port on the router) and this works fine but I can't ping an actual machine (172.16.99.20).
If some one could help me I would be very grateful.
As you can tell I am RouterOS Newbie!!
Thanks