I have two ISP channels by ether1 & ether2 interfaces with static IP. IF first main channel - down, traffic must go to second interface.
ether1 = x1.x2.x3.x4
ether2 = y1.y2.y3.y4
I write two IP addresses to Mikrotik Router and two SRC-NAT rule for each interface:
Code: Select all
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=ether1 src-address=192.168.1.0/24
add action=masquerade chain=srcnat disabled=no out-interface=ether2 src-address=192.168.1.0/24
I write two Route strings with check gateways:
Code: Select all
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=<ip gw1> pref-src=<ISP1 ip address> scope=30 target-scope=10
add check-gateway=ping disabled=no distance=5 dst-address=0.0.0.0/0 gateway=<ip gw2> pref-src=<ISP2 ip address> scope=30 target-scope=10
Code: Select all
ping 8.8.8.8 -t
ping from computer is failed... and no up! Some moment ago ping from router itself go on. but ping from computer not go:
ping 8.8.8.8 -t - failed, BUT NEW ping other external IP go successfull. Sniffer show than ICMP ping packet to destanation IP=8.8.8.8 go from ether2 with IP address of ether1 (x1.x2.x3.x4)! What the f*ck?
If one channel is PPPoE - no this problem with NAT!