Community discussions

MikroTik App
 
EarthStation
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 72
Joined: Mon May 24, 2010 4:06 pm

First Time User Manager operation - assistance please.

Mon Dec 03, 2012 10:36 am

Hi, we have decided to offer capped packages for the first time, so want to use PPPOE with UserManager and Radius(no hotspot). All code and UM on RB800.

This is what we have so far.

User Manager setup; The IP we have listed for the router is the same IP as the WLAN that the users connect on. But we are looking at giving PPPOE users an address from a PPPOE Pool, although their wireless CPE has an IP that allows to connect to the WLAN.
/tool user-manager customer
add backup-allowed=yes currency="\$" disabled=no login=admin password=snoopy paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no permissions=owner signup-allowed=no time-zone=-00:00
add backup-allowed=no currency="\$" disabled=no login=ellse parent=admin password=snoopy paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no permissions=read-only signup-allowed=no \
    time-zone=-00:00
/tool user-manager profile
add name="3GB per month" name-for-users=3GB override-shared-users=off owner=admin price=20 starts-at=logon validity=4w2d
/tool user-manager profile limitation
add address-list="" download-limit=0B group-name="" ip-pool="" name=3GB rate-limit-burst-rx=524288B rate-limit-burst-time-rx=3s rate-limit-burst-time-tx=3s rate-limit-burst-treshold-rx=204800B \
    rate-limit-burst-treshold-tx=204800B rate-limit-burst-tx=524288B rate-limit-min-rx=262144B rate-limit-min-tx=262144B rate-limit-priority=3 rate-limit-rx=262144B rate-limit-tx=262144B transfer-limit=\
    3221225472B upload-limit=0B uptime-limit=0s
add address-list="" download-limit=0B group-name="" ip-pool="" name=1GB rate-limit-burst-rx=524288B rate-limit-burst-time-rx=3s rate-limit-burst-time-tx=3s rate-limit-burst-treshold-rx=204800B \
    rate-limit-burst-treshold-tx=204800B rate-limit-burst-tx=524288B rate-limit-min-rx=262144B rate-limit-min-tx=262144B rate-limit-priority=3 rate-limit-rx=262144B rate-limit-tx=262144B transfer-limit=\
    1073741824B upload-limit=0B uptime-limit=0s
/tool user-manager profile profile-limitation
add from-time=0s limitation=3GB profile="3GB per month" till-time=23h59m59s weekdays=sunday,monday,tuesday,wednesday,thursday,friday,saturday
/tool user-manager router
add coa-port=1700 customer=admin disabled=no ip-address=10.254.253.254 log=auth-ok,auth-fail,acct-ok,acct-fail name="MainHiSite Router" shared-secret=1234
/tool user-manager user
add caller-id=bind customer=admin disabled=no ip-address=172.16.10.254 name=ellse password=snoopy shared-users=1 wireless-enc-algo=none wireless-enc-key="" wireless-psk=""
RADIUS on Mikrotik:
/radius
add accounting-backup=no accounting-port=1813 address=10.254.253.254 authentication-port=1812 called-id="" disabled=no domain="" realm="" secret=1234 service=ppp timeout=300ms
/radius incoming
set accept=yes port=3799
PPP:
/ppp profile
set 0 change-tcp-mss=yes name=default only-one=default remote-ipv6-prefix-pool=none use-compression=default use-encryption=default use-ipv6=yes use-mpls=default use-vj-compression=default
add change-tcp-mss=default dns-server=8.8.8.8,8.8.4.4 local-address=10.254.253.254 name=pppoe-profile only-one=default remote-address=pppoe-users-pool use-compression=default use-encryption=default \
    use-ipv6=no use-mpls=default use-vj-compression=default
set 2 change-tcp-mss=yes name=default-encryption only-one=default remote-ipv6-prefix-pool=none use-compression=default use-encryption=yes use-ipv6=yes use-mpls=default use-vj-compression=default
/ppp aaa
set accounting=yes interim-update=0s use-radius=yes
/ppp secret
add caller-id="" disabled=yes limit-bytes-in=0 limit-bytes-out=0 name=ellse password=snakeman76 profile=pppoe-profile routes="" service=pppoe
The problem we are having is the Radius is timing out, not getting a response from UM. If we activate the PPP secret for the user, they connect fine, obviosuly not to UM, but the PPPOE server hosted on the same Mikrotik device as the WLAN (RB800 with level 6 licence).

Any assistance in overcoming this problem will be greatly appreciated.

Thanks

Brian
 
EarthStation
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 72
Joined: Mon May 24, 2010 4:06 pm

Re: First Time User Manager operation - assistance please.

Mon Dec 03, 2012 4:47 pm

So I carry on trying to get RADIUS server to talk to UM. Redid the entire setup as per http://wiki.mikrotik.com/wiki/User_Manager/PPP_Example and still nothing. i am using version 5.22, and that page only shows for ver 3 and 4, i assume 5.22 would the same as version 4? Would be great if I could find a page the actually works when you follow the instructions to get radius to talk to UM for PPPOE connections from a WLAN port.

Regards
Brian
 
EarthStation
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 72
Joined: Mon May 24, 2010 4:06 pm

Re: First Time User Manager operation - assistance please.

Tue Dec 04, 2012 7:54 am

And now having change the Radius and user manager router IP to 127.0.0.1 ( they are both on the same device) I am getting:

07:51:03 radius,debug new request 1b:1c4 code=Access-Request service=ppp called-id=MikroTik
07:51:03 radius,debug sending 1b:1c4 to 127.0.0.1:1812
07:51:03 radius,debug,packet sending Access-Request with id 22 to 127.0.0.1:1812
07:51:03 radius,debug,packet Signature = 0x34c220ce445ea55620f00ae8d98b10cd
07:51:03 radius,debug,packet Service-Type = 2
07:51:03 radius,debug,packet Framed-Protocol = 1
07:51:03 radius,debug,packet NAS-Port = 260
07:51:03 radius,debug,packet NAS-Port-Type = 15
07:51:03 radius,debug,packet User-Name = "ellse"
07:51:03 radius,debug,packet Calling-Station-Id = "00:0C:42:31:A1:F4"
07:51:03 radius,debug,packet Called-Station-Id = "MikroTik"
07:51:03 radius,debug,packet NAS-Port-Id = "wlan1"
07:51:03 radius,debug,packet MS-CHAP-Challenge = 0x758967d3c6a02387e6ba2bc0d557b07c
07:51:03 radius,debug,packet MS-CHAP2-Response = 0x010003c8be7e730be400abd1efec5567
07:51:03 radius,debug,packet e7a300000000000000009caf4fd29de2
07:51:03 radius,debug,packet d170e54f2a6c447979f42314e3d785c3
07:51:03 radius,debug,packet 9ca9
07:51:03 radius,debug,packet NAS-Identifier = "EarthStation HiSite"
07:51:03 radius,debug,packet NAS-IP-Address = 127.0.0.1

Still no joy :(

Regards
Brian
 
EarthStation
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 72
Joined: Mon May 24, 2010 4:06 pm

Re: First Time User Manager operation - assistance please.

Tue Dec 04, 2012 9:43 am

Ok, so no suggestions from the forum, so have now implemented http://wiki.mikrotik.com/wiki/User_Manager/4/PPP_Setup, and still no success.

On that page the part that puzzles me is "'127.0.0.1' is the address of the PPPoE-server router. 'shared-secret' should match on both User Manager and PPPoE-server routers. " when the local IP we are told to set in the PPP Profile is 10.0.0.1? The radius setup uses 127.0.0.1 and the UM router is set as 127.0.0.1, so I am not sure what PPPOE server we are expecting to find on 127.0.0.1 if we have set it as 10.0.0.1?

Regards
Brian
 
ywis
just joined
Posts: 17
Joined: Wed Jul 18, 2007 10:46 pm

First Time User Manager operation - assistance please.

Tue Jan 01, 2013 1:09 am

Did you resolve this?


Sent from my iPad using Tapatalk HD

Who is online

Users browsing this forum: No registered users and 7 guests