Community discussions

MikroTik App
 
Latif123
just joined
Topic Author
Posts: 16
Joined: Fri Nov 09, 2012 12:24 pm

difference b/w NTH and PCC load balancing

Wed Dec 12, 2012 9:22 am

Dear,

Any one please help me out to solve my question. Actually I have 1 Lan and 2 Wan Setup in my office. I want load balancing in ROS 5.18. Please suggest me which option is suitable for me.

actually some time my 1 WAN link goes down and I dont want my user's to get disconnect, or my WAN traffic automatically divert to 2nd WAN. in this scenario which load balancing is suitable for me. I have also setup Proxy cache server.
 
User avatar
asaleh75
Trainer
Trainer
Posts: 193
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: difference b/w NTH and PCC load balancing

Thu Dec 13, 2012 7:08 pm

You can try with following command. You have to change interface name and ip address as per your Router.
/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
 
Latif123
just joined
Topic Author
Posts: 16
Joined: Fri Nov 09, 2012 12:24 pm

Re: difference b/w NTH and PCC load balancing

Thu Dec 13, 2012 8:43 pm

Thanks alot Syed Abu Saleh,

but pls tell me is this NTH or PCC load balancing?
 
User avatar
asaleh75
Trainer
Trainer
Posts: 193
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: difference b/w NTH and PCC load balancing

Thu Dec 13, 2012 8:47 pm

Thanks alot Syed Abu Saleh,

but pls tell me is this NTH or PCC load balancing?
It's PCC load balancing.
 
Robotics909
just joined
Posts: 18
Joined: Wed Oct 31, 2012 5:14 pm

Re: difference b/w NTH and PCC load balancing

Sat Dec 15, 2012 8:49 am

AOA,

How are you. I am using RB 750 Router board. I have use 2 different isp and do that PCC script for load balancing and load merging. I face a problem when i try to upload something Filezilla FTP. My FTP not working when both Isp are working. So i disable one ISP then do the uploading. Can you please tell me what should i do to solve this problem or how can i exempt some ips from the the PCC rule. So theses ip only use one isp for uploading. I thing u understand the problem.

Thanks
 
User avatar
asaleh75
Trainer
Trainer
Posts: 193
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: difference b/w NTH and PCC load balancing

Sat Dec 15, 2012 8:41 pm

AOA,

How are you. I am using RB 750 Router board. I have use 2 different isp and do that PCC script for load balancing and load merging. I face a problem when i try to upload something Filezilla FTP. My FTP not working when both Isp are working. So i disable one ISP then do the uploading. Can you please tell me what should i do to solve this problem or how can i exempt some ips from the the PCC rule. So theses ip only use one isp for uploading. I thing u understand the problem.

Thanks
As per your mail please remove following mangle first.
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
 
User avatar
asaleh75
Trainer
Trainer
Posts: 193
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: difference b/w NTH and PCC load balancing

Sat Dec 15, 2012 8:52 pm

Dear Robotics909,
You have to use following code:
/ip firewall address-list
add address=172.16.0.2 list=usere-exempted-from-pcc

/ip firewall mangle
add action=accept chain=prerouting disabled=no src-address-list=user-exempted-from-pcc
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
 
Latif123
just joined
Topic Author
Posts: 16
Joined: Fri Nov 09, 2012 12:24 pm

Re: difference b/w NTH and PCC load balancing

Mon Dec 17, 2012 8:51 am

JazakAllah Dear Syed Abu Saleh,

I found very usefull information and help. May Allah Bless you. Ameen
 
Latif123
just joined
Topic Author
Posts: 16
Joined: Fri Nov 09, 2012 12:24 pm

Re: difference b/w NTH and PCC load balancing

Sat Jan 19, 2013 9:57 am

Dear abu saleh,

please confirm me, will my proxy work in PCC load balancing with 1 Lan and 2 WAN?
 
User avatar
asaleh75
Trainer
Trainer
Posts: 193
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: difference b/w NTH and PCC load balancing

Mon Feb 18, 2013 12:56 pm

Yes, Proxy will work also.
 
abcwarbot
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Apr 25, 2010 9:23 pm

Re: difference b/w NTH and PCC load balancing

Mon May 20, 2013 9:40 am

Hi all.

How many PCC can i have in the same box..?
I need to have PCC for my LAN and also PCC for my cache server on a different port with different subnet..?
Can it be done with 2 PCC ..?



Bests regards.
 
User avatar
asaleh75
Trainer
Trainer
Posts: 193
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: difference b/w NTH and PCC load balancing

Sun Jun 16, 2013 11:43 am

Yes, you can
 
Riajul74
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Sun Feb 10, 2013 12:01 am

Re: difference b/w NTH and PCC load balancing

Sun Jul 28, 2013 6:40 pm

Dear Robotics909,
You have to use following code:
/ip firewall address-list
add address=172.16.0.2 list=usere-exempted-from-pcc

/ip firewall mangle
add action=accept chain=prerouting disabled=no src-address-list=user-exempted-from-pcc
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
hello, i back this tropic after long day finished. i am already problem on this. i am also using loadbalancing with pcc . for ftp problem you suggest to add those rules.

my question is, will i remove my mangle old two rule and add those two ? or i will keep my loadbalancing as it is and add those rules which you adviced ?
another, if i load those two rules, will this continue loadbalancing for my ftp download ?

hope you will help.

best
 
User avatar
asaleh75
Trainer
Trainer
Posts: 193
Joined: Thu Nov 17, 2011 2:51 pm
Location: Dhaka, Bangladesh
Contact:

Re: difference b/w NTH and PCC load balancing

Fri Sep 20, 2013 9:47 am

hello, i back this tropic after long day finished. i am already problem on this. i am also using loadbalancing with pcc . for ftp problem you suggest to add those rules.

my question is, will i remove my mangle old two rule and add those two ? or i will keep my loadbalancing as it is and add those rules which you adviced ?
another, if i load those two rules, will this continue loadbalancing for my ftp download ?

hope you will help.

best
Do you have any problem now?
 
User avatar
moazdabsheh
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Mon Mar 24, 2014 3:10 am
Location: Palestine

Re: difference b/w NTH and PCC load balancing

Sun Apr 27, 2014 2:16 am

what about UserManager ?
will this PCC work well with UserManager?
I used it but the problem all traffic are going through WAN1 only !!!
 
zahermohamed
just joined
Posts: 1
Joined: Fri Nov 11, 2016 2:03 pm

Re: difference b/w NTH and PCC load balancing

Fri Nov 11, 2016 2:47 pm

Dear,

Any one please help me out to solve my question. Actually I have 1 Lan and 3 Wan Setup in my office. I want load balancing in ROS 5.18. Please suggest me which option is suitable for me.

actually some time my 1 WAN link goes down and I dont want my user's to get disconnect, or my WAN traffic automatically divert to3nd WAN. in this scenario which load balancing is suitable for me. I have also setup Proxy cache server.

Who is online

Users browsing this forum: No registered users and 10 guests