I think this will work but it
is untested, please use carefully!
Review the export below and adjust to your settings as I do not know the exact setup and am not there to ensure so.
*Make sure the wlan interface on each device is called wlan1, if not adjust the script below to the correct name.
*Adjust the wireless frequency to a low interference channel based on a spectral scan to see which channel has less interference.
*Ensure the ethernet cable is connected from the modem (any LAN port on the modem) to ether port 1 on the omnitik.
*Ensure the ethernet cable is connected from ether port 2 on the CPE to a unmanaged switch; LAN port on a router; or directly into a pc nic card.
Run each set of commands on each AP and you should have your extended network. Please bear in mind this was written with the assumption the devices have a fresh and clean config.
Omnitik:
ros code
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods=passthrough mode=dynamic-keys \
name=default-encryption supplicant-identity=MikroTik wpa2-pre-shared-key=\
MySecurePass
/interface wireless
set 0 band=5ghz-a/n channel-width=20/40mhz-ht-below disabled=\
no frequency=5825 hide-ssid=no ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 \
mode=ap-bridge security-profile=default-encryption ssid=mylink wds-mode=\
none wireless-protocol=any
/interface bridge
add l2mtu=1522 name=br0
/interface bridge port
add bridge=br0 interface=ether1
add bridge=br0 interface=wlan1
CPE:
ros code
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods=passthrough mode=dynamic-keys \
name=default-encryption supplicant-identity=MikroTik wpa2-pre-shared-key=\
MySecurePass
/interface wireless
set 0 band=5ghz-a/n channel-width=20/40mhz-ht-below disabled=\
no frequency=5825 hide-ssid=no ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 \
mode=station-bridge security-profile=default-encryption ssid=mylink wds-mode=\
none wireless-protocol=any
/interface bridge
add l2mtu=1522 name=br0
/interface bridge port
add bridge=br0 interface=ether2
add bridge=br0 interface=wlan1
If this works Karma is appreciated
Happy Holidays,
Nick