RB1100AH vlan and DHCP problems [SOLVED]
Posted: Sun Dec 23, 2012 2:13 am
Ok so I have come to the conclusion vlans do not work on ports 1-10 on the RB1100AH due to the chips? im guessing based on a-lot of other topics discussing vlans and RB1100AH and 4 days of tinkering and never getting a working solution, So i must use ports 11-13 to accomplish what is needed as they are not tied to a switch chip at all, this does put a damper on things but we can get by going that route until i come up with another solution.
The problem im running into is the RB1100AH when dhcp-server is enabled on that bridge, the log gets flooded every 5 seconds with:
for every access point that is connected to the management vlan.
So i tried setting static IP's, they can see eachother in /ip neighbors but when i try and ping any of them they just timeout, but yet they can telnet by mac only between eachother.
I dont know what to do. Im really lost.
Heres my setup on each device, starting from the main router (RB1100AH)
RB1100AH:
RB411GL:
last Omnitik UPA-5HnD - Same config deployed on all Omnitik's
Can anyone see what i'm doing wrong and have any suggestions for the vlan issue on the RB1100AH?
EDIT: After going over the settings for the 20th time, I realized I still had ether13 on the RB1100AH still in a bridge, removing the port from the old bridge allowed all traffic and network seems to pass and assign dhcp addresses.
The problem im running into is the RB1100AH when dhcp-server is enabled on that bridge, the log gets flooded every 5 seconds with:
Code: Select all
Management offering lease 10.52.100.2 for D4:CA:6D:55:90:F1 without success
So i tried setting static IP's, they can see eachother in /ip neighbors but when i try and ping any of them they just timeout, but yet they can telnet by mac only between eachother.
I dont know what to do. Im really lost.
Heres my setup on each device, starting from the main router (RB1100AH)
RB1100AH:
Code: Select all
/interface bridge
add l2mtu=1594 name=br-hotspot
add l2mtu=1596 name=br-pppoe
add l2mtu=1594 name=br-management
/interface ethernet
set 1 comment="Omni 5Ghz AP"
set 2 comment=WAN1
set 3 comment=WAN2
set 4 comment="Office Switch"
set 7 comment="NE 2.4Ghz AP"
set 8 comment="W 2.4Ghz AP"
set 9 comment="SE 2.4Ghz AP"
set 10 comment="Omni 5Ghz AP"
/interface vlan
add interface=ether13 l2mtu=1596 name=e13-vlan25 vlan-id=25
add interface=ether13 l2mtu=1596 name=e13-vlan15 vlan-id=15
add interface=ether13 l2mtu=1596 name=e13-vlan35 vlan-id=35
add interface=ether6 l2mtu=1594 name=e6-vlan15 vlan-id=15
add interface=ether6 l2mtu=1594 name=e6-vlan25 vlan-id=25
add interface=ether7 l2mtu=1594 name=e7-vlan15 vlan-id=15
add interface=ether8 l2mtu=1594 name=e8-vlan15 vlan-id=15
add interface=ether7 l2mtu=1594 name=e7-vlan25 vlan-id=25
add interface=ether8 l2mtu=1594 name=e8-vlan25 vlan-id=25
/interface bridge port
add bridge=br-hotspot interface=e6-vlan15
add bridge=br-management interface=e6-vlan25
add bridge=br-hotspot interface=e7-vlan15
add bridge=br-management interface=e7-vlan25
add bridge=br-hotspot interface=e8-vlan15
add bridge=br-management interface=e8-vlan25
add bridge=br-hotspot interface=e13-vlan15
add bridge=br-management interface=e13-vlan25
add bridge=br-pppoe interface=e13-vlan35
add bridge=br-management interface=ether3
add bridge=br0 interface=ether13
/interface ethernet switch port
set 0 vlan-mode=fallback
set 1 vlan-mode=fallback
set 2 vlan-mode=fallback
set 3 vlan-mode=fallback
set 4 vlan-mode=fallback
set 5 vlan-mode=fallback
set 6 vlan-mode=fallback
set 7 vlan-mode=fallback
set 8 vlan-mode=fallback
set 9 vlan-mode=fallback
set 10 vlan-mode=fallback
set 11 vlan-mode=fallback
/ip pool
add name=PPPoE ranges=10.52.105.2-10.52.105.250
add name=Hotspot ranges=10.52.101.2-10.52.101.250
add name=Management ranges=10.52.100.2-10.52.100.250
/ip dhcp-server
add add-arp=yes address-pool=Management disabled=no interface=br-management name=\
Management
add add-arp=yes address-pool=Hotspot disabled=no interface=br-hotspot name=Hotspot
add address-pool=PPPoE interface=br-pppoe name=PPPoE
/ip address
add address=10.52.105.1/24 comment=PPPoE interface=br-pppoe
add address=10.52.101.1/24 comment=Hotspot interface=br-hotspot
add address=10.52.0.1/24 comment=Management interface=br-management
/ip dhcp-client
add default-route-distance=0 disabled=no interface=ether1 use-peer-dns=no use-peer-ntp=\
no
/ip dhcp-server network
add address=10.52.0.0/24 comment="Haven Wireless Management" dns-server=10.52.0.1 \
gateway=10.52.0.1
add address=10.52.101.0/24 comment="Haven Wireless Hotspot" dns-server=10.52.101.0 \
gateway=10.52.101.1
add address=10.52.105.0/24 comment="Haven Wireless PPPoE" dns-server=10.52.105.0 \
gateway=10.52.105.1
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=8.8.4.4,8.8.8.8
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set h323 disabled=yes
/ip neighbor discovery
set ether6 disabled=yes
set ether8 disabled=yes
set e13-vlan25 disabled=yes
set e13-vlan15 disabled=yes
set e13-vlan35 disabled=yes
set e6-vlan15 disabled=yes
set e6-vlan25 disabled=yes
set e7-vlan15 disabled=yes
set e8-vlan15 disabled=yes
set e7-vlan25 disabled=yes
set e8-vlan25 disabled=yes
set br-hotspot disabled=yes
set br-pppoe disabled=yes
/ip proxy
set max-cache-size=none
/ip service
set telnet disabled=yes
set ftp disabled=yes
set ssh disabled=yes
set www-ssl certificate=cert2 disabled=no
set api disabled=no
Code: Select all
/interface bridge
add l2mtu=1522 name=br-management protocol-mode=rstp
add l2mtu=1522 name=br-hotspot protocol-mode=rstp
add l2mtu=1522 name=br-pppoe protocol-mode=rstp
/interface vlan
add interface=ether1 l2mtu=1522 name=vlan-15 vlan-id=15
add interface=ether1 l2mtu=1522 name=vlan-25 vlan-id=25
add interface=ether1 l2mtu=1522 name=vlan-35 vlan-id=35
/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods=passthrough mode=dynamic-keys \
name=default-encryption wpa2-pre-shared-key=**************
/interface wireless
set 0 band=5ghz-a/n channel-width=20/40mhz-ht-below comment=HavenMesh \
disabled=no frequency=5825 hide-ssid=yes ht-rxchains=0,1 ht-txchains=0,1 \
l2mtu=2290 mode=ap-bridge security-profile=default-encryption ssid=\
HavenMesh wds-default-bridge=br-management wds-mode=dynamic-mesh \
wireless-protocol=802.11
add area="" arp=enabled bridge-mode=enabled default-ap-tx-limit=0 \
default-authentication=yes default-client-tx-limit=0 default-forwarding=yes \
disable-running-check=no disabled=no hide-ssid=yes l2mtu=2290 mac-address=\
D6:CA:6D:11:9E:1B master-interface=wlan1 max-station-count=2007 mtu=1500 \
multicast-helper=default name=wlan3 proprietary-extensions=post-2.9.25 \
security-profile=default-encryption ssid=HavenPPPoE update-stats-interval=\
disabled wds-cost-range=0 wds-default-bridge=none wds-default-cost=0 \
wds-ignore-ssid=no wds-mode=disabled wmm-support=disabled
/interface wireless manual-tx-power-table
set wlan1 comment=HavenPPPoE
/interface wireless nstreme
set wlan1 comment=HavenPPPoE
/interface wireless wds
add disabled=no l2mtu=2290 master-interface=wlan1 name=wds1 wds-address=\
D4:CA:6D:36:CE:01
/interface vlan
add interface=wds1 l2mtu=2286 name=wvlan15 vlan-id=15
add interface=wds1 l2mtu=2286 name=wvlan25 vlan-id=25
add interface=wds1 l2mtu=2286 name=wvlan35 vlan-id=35
/interface bridge port
add bridge=br-hotspot interface=vlan-15
add bridge=br-hotspot interface=wvlan15
add bridge=br-management interface=vlan-25
add bridge=br-pppoe interface=vlan-35
add bridge=br-pppoe interface=wvlan35
add bridge=br-pppoe interface=wlan3
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip address
add address=10.52.101.1/24 interface=br-management
/ip dhcp-client
add default-route-distance=0 disabled=no interface=ether1
add default-route-distance=0 interface=br-management
add default-route-distance=0 interface=br-hotspot
/ip neighbor discovery
set wlan1 disabled=yes
set wds1 disabled=yes
set vlan-15 disabled=yes
set vlan-25 disabled=yes
set vlan-35 disabled=yes
set wvlan15 disabled=yes
set wvlan25 disabled=yes
set wvlan35 disabled=yes
set wlan3 disabled=yes
Code: Select all
/interface bridge
add l2mtu=2286 name=br-management protocol-mode=rstp
add l2mtu=2286 name=br-hotspot protocol-mode=rstp
add l2mtu=2286 name=br-pppoe protocol-mode=rstp
/interface ethernet
set 1 poe-out=off
set 2 poe-out=off
set 3 poe-out=off
set 4 poe-out=off
/interface vlan
add interface=ether2 l2mtu=1594 name=e2-vlan15 vlan-id=15
add interface=ether2 l2mtu=1594 name=e2-vlan25 vlan-id=25
add interface=ether3 l2mtu=1594 name=e3-vlan15 vlan-id=15
add interface=ether4 l2mtu=1594 name=e4-vlan15 vlan-id=15
add interface=ether3 l2mtu=1594 name=e3-vlan25 vlan-id=25
add interface=ether4 l2mtu=1594 name=e4-vlan25 vlan-id=25
/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods=passthrough mode=dynamic-keys \
name=default-encryption supplicant-identity="" wpa2-pre-shared-key=\
*************
/interface wireless
set 0 band=5ghz-a/n channel-width=20/40mhz-ht-below country="united states" \
disabled=no frequency=5825 hide-ssid=yes ht-rxchains=0,1 ht-txchains=0,1 \
hw-retries=10 l2mtu=2290 mode=ap-bridge security-profile=\
default-encryption ssid=HavenMesh wds-default-bridge=br-management \
wds-mode=dynamic-mesh wireless-protocol=802.11
add area="" arp=enabled bridge-mode=enabled default-ap-tx-limit=0 \
default-authentication=yes default-client-tx-limit=0 default-forwarding=\
yes disable-running-check=no disabled=no hide-ssid=yes l2mtu=2290 \
mac-address=D6:CA:6D:36:CE:01 master-interface=wlan1 max-station-count=\
2007 mtu=1500 multicast-helper=default name=wlan2 proprietary-extensions=\
post-2.9.25 security-profile=default-encryption ssid=HavenPPPoE \
update-stats-interval=disabled wds-cost-range=0 wds-default-bridge=none \
wds-default-cost=0 wds-ignore-ssid=no wds-mode=disabled wmm-support=\
disabled
/interface wireless wds
add disabled=no l2mtu=2290 master-interface=wlan1 name=wds1 wds-address=\
D4:CA:6D:11:9E:1B
/interface vlan
add interface=wds1 l2mtu=2286 name=wvlan15 vlan-id=15
add interface=wds1 l2mtu=2286 name=wvlan25 vlan-id=25
add interface=wds1 l2mtu=2286 name=wvlan35 vlan-id=35
/interface bridge port
add bridge=br-management interface=wvlan25
add bridge=br-hotspot interface=wvlan15
add bridge=br-hotspot interface=e2-vlan15
add bridge=br-pppoe interface=wvlan35
add bridge=br-pppoe interface=wlan2
add bridge=br-management interface=e2-vlan25
add bridge=br-management interface=e3-vlan25
add bridge=br-management interface=e4-vlan25
add bridge=br-hotspot interface=e3-vlan15
add bridge=br-hotspot interface=e4-vlan15
/interface pppoe-server server
add disabled=no service-name=service1
/interface wireless align
set receive-all=yes
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip address
add address=10.52.101.2/32 interface=br-management network=10.52.101.2
/ip dhcp-client
add default-route-distance=0 interface=br-management
add default-route-distance=0 disabled=no interface=wvlan15
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=\
192.168.0.252,192.168.0.253
/ip dns static
add address=192.168.88.1 name=router
/ip neighbor discovery
set wlan1 disabled=yes
set wvlan15 disabled=yes
set wvlan25 disabled=yes
set wvlan35 disabled=yes
set e2-vlan15 disabled=yes
set e2-vlan25 disabled=yes
set e3-vlan15 disabled=yes
set e4-vlan15 disabled=yes
set e3-vlan25 disabled=yes
set e4-vlan25 disabled=yes
set wds1 disabled=yes
set wlan2 disabled=yes
Can anyone see what i'm doing wrong and have any suggestions for the vlan issue on the RB1100AH?
EDIT: After going over the settings for the 20th time, I realized I still had ether13 on the RB1100AH still in a bridge, removing the port from the old bridge allowed all traffic and network seems to pass and assign dhcp addresses.