Hi,
if I understood you have two wan ports on MKT (WAN1, WAN2), WAN1 is default route in our scenario, WAN2 will be used for HTTP traffic which will be coming from local computers.
1) we must mark web traffic which is coming to mikrotik (ip firewall mangle)- put that rule on the top of the mangle (change in-interface LAN with your real local interface)
/ip firewall mangle
add chain=prerouting action=mark-routing new-routing-mark=web_traffic passthrough=no protocol=tcp dst-address-type=!local in-interface=LAN dst-port=80
2) we must create default route for that traffic (in our case it is WAN2)
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=WAN2 routing-mark=web_traffic scope=30 target-scope=10