I have posted it some days ago, but didnt got any reply. And later on, I tried to change the code which i pasted in my post because i did some changing though. But then, i could not see my topic at all. So i have to start this topic ,,, sorry moderators (i'm new here)
I have 4 Wans, in which All are 4mbps except WAN2 which is 10mb. I tried to do load balancing with PCC un equal method,, and i am getting speed of around 16,, (almost 4mb from all,, Wan2(10mb link) is also giving not more than 4.3-4.5).
So Kindly see my code and correct me where i am wrong.
Code: Select all
/interface ethernet
set 0 name=WAN4
set 1 name=WAN3
set 2 name=WAN2
set 3 name=Local
set 4 name=WAN1
/ip address
add address=192.168.1.1/24 interface=Local
add address=192.168.10.2/24 interface=WAN1
add address=192.168.20.2/24 interface=WAN2
add address=192.168.30.2/24 interface=WAN3
add address=192.168.40.2/24 interface=WAN4
/ip dns
set allow-remote-requests=yes cache-size=5000KiB max-udp-packet-size=512 servers=208.67.220.220,208.67.222.222
/ip firewall mangle
add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=WAN1_conn
add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=WAN2_conn
add action=mark-connection chain=input in-interface=WAN3 new-connection-mark=WAN3_conn
add action=mark-connection chain=input in-interface=WAN4 new-connection-mark=WAN4_conn
add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
add action=mark-routing chain=output connection-mark=WAN3_conn new-routing-mark=to_WAN3
add action=mark-routing chain=output connection-mark=WAN4_conn new-routing-mark=to_WAN4
add chain=prerouting dst-address=192.168.10.0/24 in-interface=Local
add chain=prerouting dst-address=192.168.20.0/24 in-interface=Local
add chain=prerouting dst-address=192.168.30.0/24 in-interface=Local
add chain=prerouting dst-address=192.168.40.0/24 in-interface=Local
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN1_conn per-connection-classifier=\
both-addresses-and-ports:4/0
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN3_conn per-connection-classifier=\
both-addresses-and-ports:4/2
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN4_conn per-connection-classifier=\
both-addresses-and-ports:4/1
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN2_conn per-connection-classifier=\
both-addresses-and-ports:4/3
add action=mark-connection chain=prerouting dst-address-type=!local in-interface=Local new-connection-mark=WAN2_conn per-connection-classifier=\
both-addresses-and-ports:4/4
add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=Local new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=Local new-routing-mark=to_WAN2
add action=mark-routing chain=prerouting connection-mark=WAN3_conn in-interface=Local new-routing-mark=to_WAN3
add action=mark-routing chain=prerouting connection-mark=WAN4_conn in-interface=Local new-routing-mark=to_WAN4
/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
add action=masquerade chain=srcnat out-interface=WAN3
add action=masquerade chain=srcnat out-interface=WAN4 to-addresses=0.0.0.0
/ip route
add check-gateway=ping distance=1 gateway=192.168.10.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.20.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.30.1 routing-mark=to_WAN3
add check-gateway=ping distance=1 gateway=192.168.40.1 routing-mark=to_WAN4
add check-gateway=ping distance=1 gateway=192.168.10.1
add check-gateway=ping distance=2 gateway=192.168.20.1
add check-gateway=ping distance=3 gateway=192.168.30.1
add check-gateway=ping distance=4 gateway=192.168.40.1