Wireless bonding technique.
Posted: Fri Mar 15, 2013 11:56 am
I have repeatedly seen a question about wireless cards bonding. Usually offered tunneling scheme(like EoIP) works quite well but dramatically decreases performance.
In my practice I use aggregation of wireless interfaces through VLAN.
General principles set out below: AP side settings.
1. Create bridge
2. Prepare wireless interfaces in bridge mode with different SSID and freq.
3. Create VLAN with different tags and bind them to an every of wireless interfaces.
4. Create a bonding interface and put the previously created VLAN here.
5. Put ethernet and bonding interface into bridge.
6. Add IP address for management and bind it to the bridge. Add IP address for link monitoring and bind it to the bonding.
STA side settings.
Same as AP except wireless mode and IP addresses.
In result we have the aggregate wireless bridge with kept transparency and performance:
In my practice I use aggregation of wireless interfaces through VLAN.
General principles set out below: AP side settings.
1. Create bridge
Code: Select all
/interface bridge
add l2mtu=1526 name=BasicBridge#1
Code: Select all
/interface wireless
set 0 band=5ghz-onlyn disabled=no disconnect-timeout=15s frequency=5260 \
frequency-mode=superchannel hide-ssid=yes ht-rxchains=0,1 ht-txchains=0,1 \
hw-protection-mode=rts-cts l2mtu=2290 mode=bridge name=R52n-M#1 \
nv2-preshared-key=Channel#1_key nv2-security=enabled \
periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
AP_R52n-M#1 scan-list=5200-5600 ssid=Channel#1 wds-mode=\
dynamic wireless-protocol=nv2
set 1 band=5ghz-onlyn disabled=no disconnect-timeout=15s frequency=5300 \
frequency-mode=superchannel hide-ssid=yes ht-rxchains=0,1 ht-txchains=0,1 \
hw-protection-mode=rts-cts l2mtu=2290 mode=bridge name=R52n-M#2 \
nv2-preshared-key=Channel#2_key nv2-security=enabled \
periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
AP_R52n-M#2 scan-list=5200-5600 ssid=Channel#2 wds-mode=\
dynamic wireless-protocol=nv2
Code: Select all
/interface vlan
add interface=R52n-M#1 l2mtu=2286 name=RF_VLAN#1 vlan-id=501
add interface=R52n-M#2 l2mtu=2286 name=RF_VLAN#2 vlan-id=502
Code: Select all
/interface bonding
add arp-interval=500ms arp-ip-targets=192.168.191.2 link-monitoring=arp mtu=\
1526 name=RF_Bonding#1 slaves=RF_VLAN#1,RF_VLAN#2
Code: Select all
/interface bridge port
add bridge=BasicBridge#1 interface=ether1
add bridge=BasicBridge#1 interface=RF_Bonding#1
Code: Select all
/ip address
add address=192.168.112.1/24 interface=BasicBridge#1
add address=192.168.191.1/30 interface=RF_Bonding#1
Same as AP except wireless mode and IP addresses.
Code: Select all
/interface bridge
add l2mtu=1526 name=BasicBridge#1
/interface wireless
set 0 band=5ghz-onlyn channel-width=20/40mhz-ht-above disabled=no \
disconnect-timeout=15s frequency=5260 frequency-mode=superchannel \
ht-rxchains=0,1 ht-txchains=0,1 hw-protection-mode=rts-cts l2mtu=2290 \
mode=station-bridge name=R52n-M#1 nv2-preshared-key=\
Channel#1_key nv2-security=enabled \
periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
STA_R52n-M#1 scan-list=5200-5600 ssid=Channel#1 wds-mode=\
static wireless-protocol=nv2
set 1 band=5ghz-onlyn channel-width=20/40mhz-ht-above disabled=no \
disconnect-timeout=15s frequency=5300 frequency-mode=superchannel \
ht-rxchains=0,1 ht-txchains=0,1 hw-protection-mode=rts-cts l2mtu=2290 \
mode=station-bridge name=R52n-M#2 nv2-preshared-key=\
Channel#2_key nv2-security=enabled \
periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
STA_R52n-M#2 scan-list=5200-5600 ssid=Channel#2 wds-mode=\
static wireless-protocol=nv2
/interface vlan
add interface=R52n-M#1 l2mtu=2286 name=RF_VLAN#1 vlan-id=501
add interface=R52n-M#2 l2mtu=2286 name=RF_VLAN#2 vlan-id=502
/interface bonding
add arp-interval=500ms arp-ip-targets=192.168.191.1 link-monitoring=arp mtu=\
1526 name=RF_Bonding#1 slaves=RF_VLAN#1,RF_VLAN#2
/interface bridge port
add bridge=BasicBridge#1 interface=ether1
add bridge=BasicBridge#1 interface=RF_Bonding#1
/ip address
add address=192.168.112.2/24 interface=BasicBridge#1
add address=192.168.191.2/30 interface=RF_Bonding#1