Hi Don, thanks for trying to help.
I'm not having trouble setting up the router - I do that for a living, though with Cisco gear

The weird bit is that static DHCP that just won't work. I'll post what I have below:
ros code
# apr/17/2013 21:55:45 by RouterOS 6.0rc11
# software id = RXQ6-HYM7
#
/ip dhcp-server
add address-pool=default-dhcp interface=bridge-local name=default
add disabled=no interface=br10-trusted lease-time=1d name=trusted
add address-pool="media pool" disabled=no interface=br20-media lease-time=8h name=media
add address-pool=yggdrasil-pool disabled=no interface=br30-yggdrasil lease-time=3h name=yggdrasil
add address-pool="guest network" disabled=no interface=br31-guest lease-time=2h name=guest
/ip dhcp-server lease
add address=10.1.1.4 client-id=thor mac-address=8C:89:A5:C1:C5:9E server=trusted
add address=10.1.2.2 client-id=squeezebox mac-address=00:04:20:07:A9:E3 server=media
add address=10.1.1.6 client-id=xbmc mac-address=90:E6:BA:41:2F:16 server=trusted
add address=10.1.2.3 client-id=xbox mac-address=7C:ED:8D:0E:F4:42 server=media
add address=10.1.1.7 client-id=baldur mac-address=00:18:F3:45:0E:76 server=trusted
add address=10.1.1.5 client-id=tyr mac-address=00:1B:38:62:D0:32 server=trusted
add address=10.1.3.10 client-id=tyr mac-address=00:13:E8:5F:0C:B7 server=yggdrasil
add address=10.1.3.15 client-id=squeezebox mac-address=00:04:20:07:A9:E3 server=yggdrasil
add address=10.1.3.16 client-id=wii mac-address=00:1B:EA:DB:3B:5A server=yggdrasil
add address=10.1.3.17 client-id=xbox mac-address=7C:ED:8D:0E:F4:42 server=yggdrasil
/ip dhcp-server network
add address=10.1.1.0/24 comment="trusted subnet" dns-server=10.1.1.1 domain=feleus.net gateway=10.1.1.1 netmask=24 ntp-server=10.1.1.3
add address=10.1.2.0/24 comment="media subnet" dns-server=10.1.1.1 domain=feleus.net gateway=10.1.2.1 netmask=24 ntp-server=10.1.1.3
add address=10.1.3.0/24 comment="yggdrasil wlan" dns-server=10.1.1.1 domain=feleus.net gateway=10.1.3.1 netmask=24 ntp-server=10.1.1.3
add address=10.1.4.0/24 comment="guest wlan" dns-server=10.1.1.1 domain=feleus.net gateway=10.1.4.1 netmask=24
add address=192.168.88.0/24 comment="default configuration" dns-server=192.168.88.1 gateway=192.168.88.1
(Some stuff edited out - it's just static assignments that are irrelevant or even working properly.)
Now, take a look at the entries for 'squeezebox' (it's possible to connect it wired and wirelessly). This static entry won't work with the squeezebox. MAC address is 100% correct, I've been using that exact same MAC for years to configure IP for the squeezebox. It won't pick it up when DHCP is set to static, but will take an address from the pool. NOTE: the pool is just there so the devices get something, at first I didn't want any pool.
Also, note the entry for 'thor'. That's my desktop and it DOES take the static DHCP just fine. There's no pool for that network as you'll see. My laptop, tyr, also takes the static DHCP, both wired and wireless, so without and with a pool present.
I'm perfectly ok with having to take a good look at logs and whatnot, but I'm not familiar enough with RouterOS to accomplish that for now, so I need some pointers as to what I should do to increase debugging output for DHCP only, so I can see what the RB2011 thinks is going on.
Off topic: I'm really impressed with what RouterOS can do! I'm seriously considering buying a few low-end devices so I can build a lab with them (say 8 or so, likely the RB750) and I'm trying to get work to do exactly that so we can all learn how to work our new MPLS setup and how to re-create it using other gear, which should really help with understanding the whole setup. I'm so glad I stumbled upon Mikrotik's existence!