Page 1 of 1

scripting bandwidth control

Posted: Fri May 03, 2013 8:30 pm
by gabak
hi there.
question.
i have this script that make all my queues automatically , that is great.
but it has a little flaw i dont know how to solve. At the TOTAL tag at the buttom
shows default-small and that way it does nt show the transfer at all.
if i set it up in default it works fine.
what can i do to solve that in this script or how can i change all of them at once
:for e from 3 to 254 do={
/queue simple add name="user $e" target-addresses="192.168.16.$e" max-limit=384000/384000
}
thank you very much
gabe

Re: scripting bandwidth control

Posted: Sat May 04, 2013 12:21 am
by skot
Do you want to set only the total queue type setting, or all 3 of the queue types? This will change them all. If you only want the total-queue setting, just remove the queue=default/default part.

ros code

:for e from=3 to=254 do={
  /queue simple add name="user $e" target-addresses="192.168.16.$e" max-limit=384000/384000 queue=default/default total-queue=default
}
If you already have the queues created, and you want to change them, do the following.

ros code

:for e from=3 to=254 do={
  /queue simple set [find target-addresses~"192.168.16.$e"] queue=default/default total-queue=default
}

Re: scripting bandwidth control

Posted: Sun May 05, 2013 1:32 am
by gabak
thank you for the quick answer.
just i want to know who use more internet of all my internet users.
what do you recommend best?
what is good to know the other types of queues?
thxs in advance

pd: what i need to to know the total and if the user are transferring data meaning using the connection
Do you want to set only the total queue type setting, or all 3 of the queue types? This will change them all. If you only want the total-queue setting, just remove the queue=default/default part.

ros code

:for e from=3 to=254 do={
  /queue simple add name="user $e" target-addresses="192.168.16.$e" max-limit=384000/384000 queue=default/default total-queue=default
}
If you already have the queues created, and you want to change them, do the following.

ros code

:for e from=3 to=254 do={
  /queue simple set [find target-addresses~"192.168.16.$e"] queue=default/default total-queue=default
}