Bridge tagged and untagged traffic separate
Posted: Fri Aug 16, 2013 11:23 am
I am trying to bridge untagged (native vlan) traffic and tagged traffic from a Ubiqity WiFi radio. The untagged traffic is for managing the radio, the tagged traffic contains user-data from the SSIDs on the radio.
I have the vlan defined on ethernet-2. Then I have two bridges: bridge-hs-mngt and bridge-hs-data.
The problem is that when I add the ethernet-2 interface to bridge bridge-hs-mngt, all ethernet traffic is entered into this bridge. Thus INCLUDING tagged packets from the bridge-hs-data vlan. The vlan interface is added to the bridge-hs-data bridge, but no traffic enters here.
How to prevent tagged traffic from entering a bridge that has the "native" interface in it????
I have the vlan defined on ethernet-2. Then I have two bridges: bridge-hs-mngt and bridge-hs-data.
The problem is that when I add the ethernet-2 interface to bridge bridge-hs-mngt, all ethernet traffic is entered into this bridge. Thus INCLUDING tagged packets from the bridge-hs-data vlan. The vlan interface is added to the bridge-hs-data bridge, but no traffic enters here.
How to prevent tagged traffic from entering a bridge that has the "native" interface in it????
Code: Select all
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s mtu=1500 name=bridge-hs-mngt priority=0x8000 protocol-mode=none transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes disabled=no forward-delay=15s l2mtu=65535 max-message-age=20s mtu=1500 name=bridge-hs-data priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=bridge-hs-data disabled=no edge=auto external-fdb=auto horizon=none interface=vlan66 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge-hs-mngt disabled=no edge=auto external-fdb=auto horizon=none interface=ether2-master-local path-cost=10 point-to-point=auto priority=0x80
/ip address
add address=192.168.100.1/24 disabled=no interface=bridge-hs-mngt network=192.168.100.0
add address=192.168.66.1/24 disabled=no interface=bridge-hs-data network=192.168.66.0