I have added a bridge to create a trunk. I am on port 9 which is on vlan 21. my vmware host is on ports 1-3 which are part of the trunk. I have a vm on vlan 21 and I am unable to ping either the vm host or the vm itself.
/interface bridge
add name=bridge-phones
add name=bridge-san
add l2mtu=1598 name=bridge-native
add name=bridge-workstations
add name=bridge-lab
add l2mtu=1598 name=bridge-public
add name=bridge-misc
add l2mtu=1598 name=bridge-trunk
/interface vlan
add interface=bridge-phones l2mtu=65531 name=vlan-10-public vlan-id=10
add interface=bridge-san l2mtu=65531 name=vlan-20-public vlan-id=20
add interface=bridge-native l2mtu=1594 name=vlan-21-native vlan-id=21
add interface=bridge-workstations l2mtu=65531 name=vlan-30-workstations vlan-id=30
add interface=bridge-lab l2mtu=65531 name=vlan-40-lab vlan-id=40
add interface=bridge-public l2mtu=1594 name=vlan-50-public vlan-id=50
add interface=bridge-misc l2mtu=65531 name=vlan-60-misc vlan-id=60
add interface=bridge-trunk l2mtu=1594 name=vlan-10-trunk vlan-id=10
add interface=bridge-trunk l2mtu=1594 name=vlan-21-trunk vlan-id=21
add interface=bridge-trunk l2mtu=1594 name=vlan-30-trunk vlan-id=30
add interface=bridge-trunk l2mtu=1594 name=vlan-40-trunk vlan-id=40
add interface=bridge-trunk l2mtu=1594 name=vlan-50-trunk vlan-id=50
add interface=bridge-trunk l2mtu=1594 name=vlan-60-trunk vlan-id=60
/interface bridge port
add bridge=bridge-native interface=ether6
add bridge=bridge-public interface=ether7
add bridge=bridge-public interface=ether8
add bridge=bridge-native interface=ether9
add bridge=bridge-native interface=ether10
add bridge=bridge-trunk interface=ether1
add bridge=bridge-trunk interface=ether2
add bridge=bridge-trunk interface=ether3
add bridge=bridge-trunk interface=ether4
add bridge=bridge-trunk interface=ether5
/ip address
add address=10.105.10.254/24 interface=bridge-phones
add address=10.105.20.254/24 interface=bridge-san
add address=10.105.21.251/24 interface=bridge-native
add address=10.105.30.254/24 interface=bridge-workstations
add address=10.105.40.254/24 interface=bridge-lab
add address=10.105.50.254/24 interface=bridge-public
add address=10.105.60.254/24 interface=bridge-misc
/ip dns
set allow-remote-requests=yes