Greetings,
I've been trying to figure out a solution to this seemingly simple problem for about 14 hours and I hope someone has a simple solution. Basically what I'm trying to accomplish is to have a transparent web proxy for caching. If I dedicate a port on my router to be used for the LAN, my setup works flawlessly with speeds of approx 700 Mb/sec for cached content (x86-based router). As soon as I put my users on a VLAN, the speed for cached content drops to about 1.5 Mb/sec. For some reason, the web proxy has terrible issues with VLANs it seems.
Here's my setup:
I have a NAT rule to redirect web traffic through the proxy:
/ip firewall nat add action=redirect chain=dstnat dst-port=80 protocol=tcp to-ports=8080
I have my users in a VLAN:
/interface vlan add interface=ether1 l2mtu=9010 name=vlan12 vlan-id=12
I have no firewall filtering rules in my test environment
My web proxy is configured as follows:
/ip proxy set always-from-cache=yes cache-administrator=cache@admin.com cache-on-disk=yes enabled=yes max-fresh-time=100w parent-proxy=0.0.0.0
/ip proxy access add
/ip proxy cache add
As indicated previously, if my users are on the subnet of one of my physical Ethernet ports on the router, this works flawlessly and is very fast. Only users on a VLAN interface have speed issues. I suspect a MTU issue, but I can't figure it out. If I turn off my redirect NAT rule (which basically turns off the web proxy), both sets of users are able to download at full speed, but obviously without any caching.
For VLAN users, I have a port on the router going to my switch (tagged port) and I have my users connected to the switch (untagged port). By the way, I get 1.5 Mbit/sec on RouterOS version 6.x and I get about 20 Mb/sec on RouterOS version 5.x with the exact same config.
Perhaps someone here has any ideas?
Thanks