Could you please post the solution?
On the link you gave are a lot of configurations, a lot of tests, but where is the solution to the problem described?
Something like: do this command and that command and it's done. If possible without decorations of any kind...
Absolutely, I put in all the steps because I have had so much struggles with it that I dont know if it will work if leaving one of the steps below out. So I am sorry, it will be relaitively much text, hopefully it helps you out.
Daisy chanied Cisco2960, CRS A, CRS B
Cisco 2960 <--TRUNK vlans:20,100,200,220,300,400 --> ether1 [CRS A] ether13 <--TRUNK vlans:20,100,200,220,300,400 --> ether1 [CRS B]
Configuration CRS A = CRS B, two access ports on vlan 20, one access port to each one of the other vlans and vlan trunk on ether1 and ether13
CRS A is set to have admin ip on vlan200: 172.16.1.111
CRS B is set to have admin ip on vlan200: 172.16.1.112
There are some more ip settings like default gw 172.16.1.1 and dns settings plus some route to another network 192.168.1.0/24 as well.
Also I did set passwords for admin, when done using winbox.
Preparing the CRS, fully reset and netinstall RoS6.14 (all steps from console port):
1. Connecting my laptop to the console port through USB to RS232 dongle.
2. Reset the switch fully:
/system reset-configuration no-defaults=yes skip-backup=yes
Power off by plugging cable out and in.
3. Netinstall CRS the ususal way by holding in the reset button whilst putting in the power cable in and same time have netinstal running on pc.
Here is how that is done:
http://wiki.mikrotik.com/wiki/Manual:Netinstall
4. Upgrade to firmware 3.14:
/system routerboard upgrade
system reboot
5. Reset the switch fully again:
/system reset-configuration no-defaults=yes skip-backup=yes
Power off by plugging cable out and in.
Note!
On the second CRS I did simply skipped netinstall and simply upgrate to RoS6.14 and resetted + power cycled afterwards, and it worked, but hang in starting services first boot, a new power cycle and it hang in export compact, a new power cycle and then no more problems.
Configuring the switch CRS A from the console:
## BEGIN CONFIGURATION CRS A##
# 1. Configure a Switch group
/interface ethernet
set [ find default-name=ether6 ] master-port=ether1
set [ find default-name=ether7 ] master-port=ether1
set [ find default-name=ether8 ] master-port=ether1
set [ find default-name=ether9 ] master-port=ether1
set [ find default-name=ether10 ] master-port=ether1
set [ find default-name=ether11 ] master-port=ether1
set [ find default-name=ether12 ] master-port=ether1
set [ find default-name=ether13 ] master-port=ether1
# 2. Tagging should be set on ether1 because it is a VLAN trunk port.
# ether1 and ether13 is vlan trunks for vlan 20,100,200,220,300,400
# Additionally, set switch1-cpu for VLAN200 to access IP address on VLAN interface, the frames should be tagged on it as well.
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether1,ether13 vlan-id=20
add tagged-ports=ether1,ether13 vlan-id=100
add tagged-ports=ether1,ether13,switch1-cpu vlan-id=200
add tagged-ports=ether1,ether13 vlan-id=220
add tagged-ports=ether1,ether13 vlan-id=300
add tagged-ports=ether1,ether13 vlan-id=400
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=20 ports=ether6 sa-learning=yes
add new-customer-vid=100 ports=ether7 sa-learning=yes
add new-customer-vid=200 ports=ether8 sa-learning=yes
add new-customer-vid=220 ports=ether9 sa-learning=yes
add new-customer-vid=300 ports=ether10 sa-learning=yes
add new-customer-vid=400 ports=ether11 sa-learning=yes
add new-customer-vid=20 ports=ether12 sa-learning=yes
# 3. VLAN mebership should be adjusted according to VLAN tagging.
# VLAN id on ether1 and access port and for VLAN200 switch1-cpu port as well.
/interface ethernet switch vlan
add ports=ether1,ether6,ether12,ether13 vlan-id=20
add ports=ether1,ether7,ether13 vlan-id=100
add ports=ether1,ether8,ether13,switch1-cpu vlan-id=200
add ports=ether1,ether9,ether13 vlan-id=220
add ports=ether1,ether10,ether13 vlan-id=300
add ports=ether1,ether11,ether13 vlan-id=400
# 4. Other VLAN interfaces seem to be unnecessary because they do not have IP address.
/interface vlan
add interface=ether1 l2mtu=1584 name=vlan200 vlan-id=200
# 5. Put CRS A IP address on vlan200
/ip address
add address=172.16.1.111/24 interface=vlan200 network=172.16.1.0
# 6. Forward-Unknown-Vlan, MT say no, but that does not work, say yes and it works
# This has ben debatted a lot, I could never got it working with no, then swicth do not pass any traffic at all
/interface ethernet switch
set forward-unknown-vlan=yes
# 7. Other settings like routning, dns, ntp and CRS name
/ip dns
set servers=172.16.1.1
/ip dns static
add address=172.16.1.111 name=mikrotiksw1
/ip route
add distance=1 gateway=172.16.1.1
add distance=1 dst-address=192.168.0.0/16 gateway=172.16.1.253
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api-ssl disabled=yes
/lcd
set backlight-timeout=15m
/snmp
set contact="Peter Steen" enabled=yes location="Some Place" trap-community=public
/system clock
set time-zone-name=Europe/Stockholm
/system identity
set name="MikroTik SW1"
/system ntp client
set enabled=yes mode=unicast primary-ntp=10.30.0.5 secondary-ntp=172.16.1.11
## END CONFIGURATION CRS A##
The do some tests:
Connect CRS A to Cisco, try pinging it's IP 172.16.1.111 and then access from winbox and try ping default gateway, and check that time is right and DNS is working.
Connect some device at ether6 (vlan 20) and see if it accessable and so on.
If all works, go on and configure CRS B!
Now we are done with CRS A, we configured CRS B the same way, exept IP, move the console cable to CRS B
## BEGIN CONFIGURATION CRS B##
# 1. Configure a Switch group
/interface ethernet
set [ find default-name=ether6 ] master-port=ether1
set [ find default-name=ether7 ] master-port=ether1
set [ find default-name=ether8 ] master-port=ether1
set [ find default-name=ether9 ] master-port=ether1
set [ find default-name=ether10 ] master-port=ether1
set [ find default-name=ether11 ] master-port=ether1
set [ find default-name=ether12 ] master-port=ether1
set [ find default-name=ether13 ] master-port=ether1
# 2. Tagging should be set on ether1 because it is a VLAN trunk port.
# ether1 and ether13 is vlan trunks for vlan 20,100,200,220,300,400
# Additionally, set switch1-cpu for VLAN200 to access IP address on VLAN interface, the frames should be tagged on it as well.
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether1,ether13 vlan-id=20
add tagged-ports=ether1,ether13 vlan-id=100
add tagged-ports=ether1,ether13,switch1-cpu vlan-id=200
add tagged-ports=ether1,ether13 vlan-id=220
add tagged-ports=ether1,ether13 vlan-id=300
add tagged-ports=ether1,ether13 vlan-id=400
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=20 ports=ether6 sa-learning=yes
add new-customer-vid=100 ports=ether7 sa-learning=yes
add new-customer-vid=200 ports=ether8 sa-learning=yes
add new-customer-vid=220 ports=ether9 sa-learning=yes
add new-customer-vid=300 ports=ether10 sa-learning=yes
add new-customer-vid=400 ports=ether11 sa-learning=yes
add new-customer-vid=20 ports=ether12 sa-learning=yes
# 3. VLAN mebership should be adjusted according to VLAN tagging.
# VLAN id on ether1 and access port and for VLAN200 switch1-cpu port as well.
/interface ethernet switch vlan
add ports=ether1,ether6,ether12,ether13 vlan-id=20
add ports=ether1,ether7,ether13 vlan-id=100
add ports=ether1,ether8,ether13,switch1-cpu vlan-id=200
add ports=ether1,ether9,ether13 vlan-id=220
add ports=ether1,ether10,ether13 vlan-id=300
add ports=ether1,ether11,ether13 vlan-id=400
# 4. Other VLAN interfaces seem to be unnecessary because they do not have IP address.
/interface vlan
add interface=ether1 l2mtu=1584 name=vlan200 vlan-id=200
# 5. Put CRS A IP address on vlan200
/ip address
add address=172.16.1.112/24 interface=vlan200 network=172.16.1.0
# 6. Forward-Unknown-Vlan, MT say no, but that does not work, say yes and it works
# This has ben debatted a lot, I could never got it working with no, then swicth do not pass any traffic at all
/interface ethernet switch
set forward-unknown-vlan=yes
# 7. Other settings like routning, dns, ntp and CRS name
/ip dns
set servers=172.16.1.1
/ip dns static
add address=172.16.1.112 name=mikrotiksw2
/ip route
add distance=1 gateway=172.16.1.1
add distance=1 dst-address=192.168.0.0/16 gateway=172.16.1.253
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api-ssl disabled=yes
/lcd
set backlight-timeout=15m
/snmp
set contact="Peter Steen" enabled=yes location="Some Place" trap-community=public
/system clock
set time-zone-name=Europe/Stockholm
/system identity
set name="MikroTik SW1"
/system ntp client
set enabled=yes mode=unicast primary-ntp=10.30.0.5 secondary-ntp=172.16.1.11
## END CONFIGURATION CRS A##
Now connecto CRS A ether13 to CRS A ether1!
Try ping CRS B(172.16.1.112) from CRS A or any pc in vlan200.
Login using winbox to CRS B, and try ping default gw and the other switch and some else device, check the time and other stuff like DNS.