Community discussions

MikroTik App
 
mrjoli021
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 51
Joined: Tue May 28, 2013 6:16 pm

vlan trunking to vmware esxi

Sun May 11, 2014 6:28 am

I have a vmware server and I would like to create a trunk group on ports 4-5 and trunk them with all vlans. Below is my config. Please help.
# jan/14/1970 00:32:37 by RouterOS 6.11
# software id = FP7P-M89C
#
/interface bridge
add name=Trunk_ESXI protocol-mode=none
add name=bridge-lan protocol-mode=none
add l2mtu=1598 name=bridge-network protocol-mode=none
add l2mtu=1598 name=bridge-phones protocol-mode=none
add l2mtu=1600 name=bridge-public protocol-mode=none
add name=bridge-qa protocol-mode=none
add name=bridge-san protocol-mode=none

/interface ethernet
set [ find default-name=ether1 ] speed=1Gbps
set [ find default-name=ether2 ] speed=1Gbps
set [ find default-name=ether3 ] speed=1Gbps
set [ find default-name=ether4 ] speed=1Gbps
set [ find default-name=ether5 ] speed=1Gbps
set [ find default-name=ether7 ] advertise=1000M-full
set [ find default-name=ether11 ] mac-address=00:0C:42:9B:3E:00
set [ find default-name=ether12 ] mac-address=00:0C:42:9B:3E:01
set [ find default-name=ether13 ] mac-address=00:0C:42:9B:3E:02 speed=1Gbps

/interface vlan
add interface=bridge-phones l2mtu=1594 name=vlan-10-phones vlan-id=10
add interface=bridge-san l2mtu=65531 name=vlan-20-san vlan-id=20
add interface=bridge-network l2mtu=1594 name=vlan-21-network vlan-id=21
add interface=bridge-lan l2mtu=65531 name=vlan-30-lan vlan-id=30
add interface=bridge-public l2mtu=1596 name=vlan-40-wan vlan-id=40

/ip neighbor discovery
set vlan-10-phones discover=no
set vlan-20-san discover=no
set vlan-21-network discover=no
set vlan-30-lan discover=no
set vlan-40-wan discover=no

/interface ethernet switch port
set 1 default-vlan-id=21 vlan-header=add-if-missing vlan-mode=secure
set 5 vlan-header=add-if-missing

/interface bridge port
add bridge=bridge-network interface=ether3
add bridge=bridge-network interface=ether4
add bridge=bridge-network interface=ether5
add bridge=bridge-network interface=ether6
add bridge=bridge-network interface=ether7
add bridge=bridge-network interface=ether8
add bridge=bridge-network interface=ether9
add bridge=bridge-phones interface=ether10
add bridge=bridge-public interface=ether13
add bridge=bridge-phones interface=ether1