Software: v6.13
I've been using the internal SNTP client, as well as two other devices on my network, for some time now and never had issues with it. However, I recently upgraded to v6.13 and now none of the SNTP or NTP clients work. I can see packets coming in from the LAN, however they do not get sent out into the WAN as far as I can tell.
Running torch on the WAN interface, I cannot see NTP requests going out, however I can see the NTP responses coming back. The connection tracker shows the attempt as Unreplied, even when I can see the packets arriving. I have tried allowing all NTP packets in the firewall, but that did not have any effect.
The firewall/NAT configuration should be pretty standard for a home router. Here is the config:
ros code
/interface bridge add arp=proxy-arp l2mtu=1598 name=bridge_lan /interface ethernet set [ find default-name=ether1 ] name=ether1_Syx set [ find default-name=ether4 ] advertise=1000M-full name=ether4_OmniOS \ rx-flow-control=auto tx-flow-control=auto set [ find default-name=ether7 ] name=ether7_WDTV set [ find default-name=ether10 ] name=ether10_CableModem set [ find default-name=sfp1 ] disabled=yes speed=100Mbps /ip neighbor discovery set ether10_CableModem discover=no /interface wireless set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \ band=2ghz-onlyn basic-rates-a/g="" basic-rates-b=11Mbps channel-width=\ 20/40mhz-ht-below country="united states" disabled=no distance=indoors \ frequency=2462 l2mtu=2290 mode=ap-bridge rate-set=configured \ security-profile=Styx ssid=styx supported-rates-a/g=\ 12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=11Mbps \ wireless-protocol=802.11 wmm-support=enabled /ip neighbor discovery set wlan1 discover=no /ip pool add name=pool_lan ranges=192.168.88.10-192.168.88.254 /ip dhcp-server add add-arp=yes address-pool=pool_lan disabled=no interface=bridge_lan \ lease-time=1w name=dhcp_server_lan /port set 0 name=serial0 /system logging action set 0 memory-lines=100 set 1 disk-lines-per-file=100 /interface bridge port add bridge=bridge_lan interface=ether5 add bridge=bridge_lan interface=ether6 add bridge=bridge_lan interface=ether7_WDTV add bridge=bridge_lan interface=ether8 add bridge=bridge_lan interface=ether9 add bridge=bridge_lan external-fdb=yes interface=wlan1 add bridge=bridge_lan interface=ether1_Syx add bridge=bridge_lan interface=ether2 add bridge=bridge_lan interface=ether3 add bridge=bridge_lan interface=ether4_OmniOS /ip address add address=192.168.88.1/24 interface=bridge_lan network=192.168.88.0 /ip dhcp-client add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \ interface=ether10_CableModem /ip dhcp-server network add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1 /ip dns set allow-remote-requests=yes /ip firewall connection tracking set udp-timeout=20s /ip settings set tcp-syncookies=yes /ip firewall filter add chain=input comment=ICMP limit=2,5 protocol=icmp add action=log chain=input comment=NTP disabled=yes log-prefix="NTP IN" port=123 protocol=udp add action=log chain=forward comment=NTP disabled=yes log-prefix="NTP FWD" port=123 protocol=udp add chain=input comment="Established Connections" connection-state=established add chain=input comment="Related Connections" connection-state=related add action=drop chain=input comment="Drop invalid connections" connection-state=invalid add chain=forward comment="UPnP Connections" disabled=yes dst-address=192.168.88.0/24 add chain=input comment="L2TP Incoming" connection-state=new dst-port=\ 500,1701,4500 in-interface=ether10_CableModem protocol=udp add chain=input comment="PPTP Incoming" connection-state=new dst-port=1723 \ in-interface=ether10_CableModem protocol=tcp add action=log chain=input comment="Log everything else" disabled=yes \ log-prefix="DROP INPUT" add action=drop chain=input comment="Drop everything else" in-interface=\ ether10_CableModem /ip firewall nat add action=masquerade chain=srcnat out-interface=ether10_CableModem /ip service set telnet disabled=yes set ftp disabled=yes set api disabled=yes set api-ssl disabled=yes /ip upnp set allow-disable-external-interface=no enabled=yes /ip upnp interfaces add interface=ether10_CableModem type=external add interface=bridge_lan type=internal /system clock set time-zone-name=America/Puerto_Rico /system identity set name=Styx /system ntp client set enabled=yes mode=unicast primary-ntp=162.243.72.74 secondary-ntp=173.230.144.109Any help with this will be greatly appreciated. Thanks!
EDIT: Forgot to say. Previous version was 6.9. I did downgrade to that version again but NTP did not start working. I also did a routerboard upgrade, however I don't know if this would cause the problem.