What you would like to achieve is called a bridged network.
You need to create a bridge, add all the interfaces that you are using to connect your backhaul into the bridge and assign an IP address to the bridge interface (not any ethernet or wlan interfaces!).
/interface bridge
add name=bridge1
/interface bridge port
#change the interface to whatever you need
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/ip address
#use whatever IP address this device should have and make sure to include the subnet!
add address=10.0.0.1/24 interface=bridge1
As you already said in your post this is not an ideal network design and doesn't scale well, but it is the easiest one.
To study up on networking basics go here:
http://wiki.mikrotik.com/wiki/Testwiki
Once you have a better understanding of how networking works you can convert to a routed network and assign individual subnets to each link and let OSPF do the routing for you.