ok, sounds like this friend of yours deserves some good slappin. for that "Advice"
So i did some configuration and setup a test lab and yes it is true that intervlan routing is on by default. All VLAN clients can connect to each other. Still i'm having trouble blocking specific traffic by default routed between different VLANS. Hence, i am planning to implement white listing using firewall chains, but I am having trouble understanding how the fw works. Guess I have some
reading to do.
Thank you for your comment.
So that's strange, because at my testlab intervlan routing in not on by default.
This is my configuration:
Router1:
/interface vlan
add name=VLAN20 vlan-id=20 interface=ether8 disabled=no
add name=VLAN30 vlan-id=30 interface=ether8 disabled=no
Add IP addresses to VLANs:
/ip address
add address=10.10.20.1/24 interface=VLAN20
add address=10.10.30.1/24 interface=VLAN30
Router2:
/interface vlan
add name=VLAN20 vlan-id=20 interface=ether5 disabled=no
add name=VLAN30 vlan-id=30 interface=ether5 disabled=no
Add IP addresses to VLANs:
/ip address
add address=10.10.20.2/24 interface=VLAN20
add address=10.10.30.2/24 interface=VLAN30
--> Now it's possible to ping from router1 to all vlan's on router 2, visa versa.
Router 1 + 2
/interface bridge
add name=br-vlan20 disabled=no
add name=br-vlan30 disabled=no
Router1:
/interface bridge port
add interface="vlan-20" bridge="br-vlan20" disabled=no
add interface="ether7" bridge="br-vlan20" disabled=no
add interface="vlan-30" bridge="br-vlan30" disabled=no
add interface="ether6" bridge="br-vlan30" disabled=no
Router2:
/interface bridge port
add interface="vlan-20" bridge="br-vlan20" disabled=no
add interface="ether4" bridge="br-vlan20" disabled=no
add interface="vlan-30" bridge="br-vlan30" disabled=no
add interface="ether3" bridge="br-vlan30" disabled=no
--> When I connect a device on ether7 (router1) with IP: 10.10.20.20, and my laptop on ether4 (router2) communication to each other is possible.
--> But when I connect a device on ether6 (router1) with IP: 10.10.30.30 and my laptop is still on ether4 (router2), communication is not working.
Router1:
chain=forward action=accept src-address=10.10.20.0/24 dst-address=10.10.30.0/24 log=no log-prefix=""
chain=forward action=accept src-address=10.10.30.0/24 dst-address=10.10.20.0/24 log=no log-prefix=""
--> Now it's possible to ping between vlans, so intervlan is working.
But i'm wondering, because whem I look @ the following guide:
http://wiki.mikrotik.com/wiki/Manual:CRS_examples
Section: InterVLAN Routing
This configuration is much different then my config.
Can somebody explain the difference and if my configuration is correct
What's my goal:
- Management VLAN
- Default VLAN for home network (Wifi / LAN)
- Guest Wifi VLAN
- DMZ
So isolation through VLAN, but intervlan for routing between vlan's and through firewall configuation rules so only accepting traffic from one vlan to another vlan.
Any help is very welcome