Double PPTP-OUT connection to the SAME SERVER separated on two ethernet interfaces (VRF)
Posted: Sat Feb 28, 2015 11:29 pm
Hi, guys! I have a double physical link (ether1 & ether2 RB2011iL ROS v6.27) to the same ISP to establish two PPTP-OUT connection to ISP PPTP BRAS (connect-to=1.1.1.1). Every PPTP-OUT give me 80Mbit/s download speed (therefore two links).
I need to establish PPTP-OUT connect one per ethernet link. So, it was created two VRFs:
Added NAT rules:
And routes to PPTP server:
But pptp-out links couldn't be established until doesn't exist route to PPTP server in MAIN route table. So we need to add routes like:
PPTP-OUT established now, but only one route is active and used only one ethenet link:
How can i correctly put PPTP-OUT connections into VRFs?
I need to establish PPTP-OUT connect one per ethernet link. So, it was created two VRFs:
Code: Select all
[dude@gw] /ip route vrf> export compact
#
/ip route vrf
add interfaces=ether1,pptp-out1 routing-mark=vrf1
add interfaces=ether2,pptp-out2 routing-mark=vrf2
Code: Select all
[dude@gw] /ip firewall nat> export compact
#
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1 routing-table=vrf1
add action=masquerade chain=srcnat out-interface=ether2
add action=masquerade chain=srcnat out-interface=pptp-out1 routing-table=vrf1
add action=masquerade chain=srcnat out-interface=pptp-out2 routing-table=vrf2
Code: Select all
[dude@gw] /ip route> export compact
#
/ip route
add distance=1 dst-address=1.1.1.1/32 gateway=10.20.30.1 routing-mark=vrf1 vrf-interface=ether1
add distance=1 dst-address=1.1.1.1/32 gateway=10.20.30.1 routing-mark=vrf2 vrf-interface=ether2
Code: Select all
[dude@gw] /ip route> export compact
#
/ip route
add distance=1 dst-address=1.1.1.1/32 gateway=10.20.30.1%ether1
add distance=1 dst-address=1.1.1.1/32 gateway=10.20.30.1%ether2
Code: Select all
[dude@gw] /ip route> print terse where dst-address=1.1.1.1/32
3 A S dst-address=1.1.1.1/32 gateway=10.20.30.1%ether1 distance=1 scope=30 target-scope=10
4 S dst-address=1.1.1.1/32 gateway=10.20.30.1%ether2 distance=1 scope=30 target-scope=10