Done - I removed dhcp-server from Mikrotik2 and configured R2 as dhcp server.
R1 is able to receive DHCP service from R2 as expected.
ARP goes through un-altered as well. (arp is definitely a broadcast)
Here's a debug output on R2:
R1#clear ip arp 192.168.1.1
R1#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/50/76 ms
(this first missed ping is normal when a Cisco router has no arp entry)
R1#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.1.1 3 c402.1770.0000 ARPA FastEthernet0/0
Internet 192.168.1.2 - c401.1a3c.0000 ARPA FastEthernet0/0
Internet 192.168.1.4 4 0000.ab79.4d02 ARPA FastEthernet0/0
Here's the arp / ping from R2's point of view.
Note that the MAC addresses are all correct (this is only true for a true bridge)
R2#
*Mar 1 00:09:25.567: IP ARP: rcvd req src 192.168.1.2 c401.1a3c.0000, dst 192.168.1.1 FastEthernet0/0
*Mar 1 00:09:25.571: IP ARP: creating entry for IP address: 192.168.1.2, hw: c401.1a3c.0000
*Mar 1 00:09:25.571: IP ARP: sent rep src 192.168.1.1 c402.1770.0000,
dst 192.168.1.2 c401.1a3c.0000 FastEthernet0/0
R2#
*Mar 1 00:09:27.551: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.1.2
*Mar 1 00:09:27.647: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.1.2
*Mar 1 00:09:27.699: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.1.2
*Mar 1 00:09:27.715: ICMP: echo reply sent, src 192.168.1.1, dst 192.168.1.2
I am able to ping / arp / telnet / etc - to and from any of my 4 devices in the topology.
As you can see, PPtP is completely capable of doing a pure bridge, as far as Mikrotik is concerned.
If the client end is not also configured as a bridge, then that leads to issues.
Here are the updated Mikrotik configurations:
[admin@Mikrotik-1] > export compact
#
/interface bridge
add name=LAN
/ppp profile
add bridge=LAN name=pptp-bridge use-ipv6=no use-mpls=no
/interface pptp-client
add allow=mschap1,mschap2 connect-to=10.0.12.2 disabled=no mrru=1600 name=\
pptp-out1 password=R1 profile=pptp-bridge user=R1
/interface bridge port
add bridge=LAN interface=ether3
/ip address
add address=10.0.12.1/24 interface=ether2 network=10.0.12.0
add address=10.1.1.1/24 interface=ether1 network=10.1.1.0
/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no \
interface=LAN use-peer-dns=no use-peer-ntp=no
/system identity
set name=Mikrotik-1
[admin@Mikrotik-2] > export compact
#
/interface bridge
add name=LAN
/ppp profile
add bridge=LAN change-tcp-mss=yes name=pptp-bridge use-ipv6=no use-mpls=no
/interface bridge port
add bridge=LAN interface=ether3
/interface pptp-server server
set enabled=yes
/ip address
add address=10.1.1.2/24 interface=ether1 network=10.1.1.0
add address=10.0.12.2/24 interface=ether2 network=10.0.12.0
/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no \
interface=LAN use-peer-dns=no
/ppp secret
add name=R1 password=R1 profile=pptp-bridge service=pptp
/system identity
set name=Mikrotik-2