Page 1 of 1

Load balancing vs Tunnels

Posted: Wed Jul 01, 2015 12:29 pm
by dana1975
hi all

i have a problem in load balancing
i have 2 wan connection with different gateway and im using this code in my router

/interface ethernet
set [ find default-name=ether5 ] name=ISP1
set [ find default-name=ether4 ] name=ISP2
set [ find default-name=ether1 ] name=LAN

/ip address
add address=192.168.0.1/24 interface=LAN
add address=192.168.1.1/24 interface=LAN
add address=111.111.111.2/24 interface=ISP1
add address=222.222.222.2/27 interface=ISP2

/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=to_ISP1 src-address=192.168.0.0/24
add action=mark-routing chain=prerouting new-routing-mark=to_ISP2 src-address=192.168.1.0/24

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ISP1 src-address=192.168.0.0/24
add action=masquerade chain=srcnat out-interface=ISP2 src-address=192.168.1.0/24

/ip route
add distance=1 gateway=111.111.111.1 routing-mark=to_ISP1
add distance=1 gateway=222.222.222.1 routing-mark=to_ISP2
add distance=1 gateway=111.111.111.1,222.222.222.1


also i have some IPIP Tunnel in my router and i added some static router for them

/ip route
add distance=1 dst-address=192.168.3.0/24 gateway=10.10.10.1
add distance=1 dst-address=192.168.4.0/24 gateway=10.10.10.5



i have to say when i working with single wan connection everything is working fine and they have internet and connectivity to other branch simultaneously
but when i use 2 wan connection, users have only Internet OR connection to Other Branch

what shall i do ?

Re: Load balancing vs Tunnels

Posted: Sat Jul 04, 2015 10:35 am
by dana1975
has been solved !!!!

Posted: Sat Jul 04, 2015 11:57 am
by Siona
Could you describe?