Community discussions

MikroTik App
 
PhoeKhwar
just joined
Topic Author
Posts: 8
Joined: Sat Jun 08, 2013 10:28 pm

LoadBalancing For 2WAN ( Only WAN2 For port 80 and 443 )

Wed Jul 15, 2015 4:19 am

Dear ,

i `m using loadbalancing PCC method with 2 WAN , but i just want to use WAN2 for only 80,443 for loadbalancing with WAN1 ,

this is my config

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8,8.8.8.8

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade





Please Help me.
 
soyelpulpo
newbie
Posts: 38
Joined: Mon Nov 10, 2014 1:22 am
Location: Lima - Peru

Wed Jul 15, 2015 6:06 am

I was having the same issue a few days ago. First lets start by changing your need: what you really need is not load balancing. What you need is policy based routing. It is very similar but the criteria will be destination ports (80 and 443), connections that match that rule will use wan2 route and all the others wan1 route. The wiki has documentation and examples that you can modify to fit your needs. Good luck.

Sent from my Nexus 4 using Tapatalk
 
PhoeKhwar
just joined
Topic Author
Posts: 8
Joined: Sat Jun 08, 2013 10:28 pm

Re: LoadBalancing For 2WAN ( Only WAN2 For port 80 and 443 )

Thu Jul 16, 2015 1:11 am

Dear ,
Actually i have 11 WAN .Previously i posted for example....... .. i want 6WAN for all traffic including 80,443 , and the rest of 5 WAN for 80 and 443 only , if i use it to Policy Based Routing ... there is alot of bandwidth for waste ....is any solution for that ?