I am trying to configure VLAN id translation between 2 ports. It works, but I have questions.
The topology is:
vlan id 2 <===> [ ether2 ] CRS [ ether 3 ] <===> vlan id 122
The configuration is:
Code: Select all
/interface ethernet
set [ find default-name=ether2 ] name=ether2
set [ find default-name=ether3 ] master-port=ether2 name=ether3
/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports=ether2,ether3
/interface ethernet switch egress-vlan-translation
add customer-vid=2 new-customer-vid=122 ports=ether3
/interface ethernet switch ingress-vlan-translation
add customer-vid=122 new-customer-vid=2 ports=ether3 sa-learning=yes
/interface ethernet switch vlan
add ports=ether2,ether3 vlan-id=2
1/ the wiki examples mention the command egress-vlan-tag
What is it used for ? Do I need to use it ? If so, how ?
2/ if packets with vlan id 2 comes in ether3, they are forwarded to ether2 . This is unwanted.
The only way I found to prevent it is to add an ingress-vlan-translation rule to change the VLAN id to a not-defined VLAN id.
Is there a better way to achieve this ?